Archived

This topic is now archived and is closed to further replies.

i1977

No UV when exporting .X file from 3D Studio Max

Recommended Posts

I need to be able to load meshes in my program for a quick project that has to be completed in about 2 weeks. I figured I might as well use .X files since Direct3D has built in support for them. Unfortunately, all the models we export from 3D Studio Max 4.2 using the XSkinExp.dle exporter supplied by Microsoft with the DirectX 8.1 SDK do not appear to export texture coordinates. When I load the .X file in MeshViewer (in "DirectX Utilities" in the Start Menu) and choose "Mesh Properties" from the "MeshOps" menu, only the ''XYZ'' and ''Normal'' FVF flags are checked. However, if I load a .X file that''s supplied with the SDK (for example Tiger.x) the ''Tex1 UV'' field is also checked and is thus textured properly. The meshes we try to export have a single texture applied on the diffuse channel and are collapsed as mentioned in the readme file that is included along with the exporter. Does anyone know why we are not getting UV coordinates in our exported meshes or what we can do to fix this problem?

Share this post


Link to post
Share on other sites
Like Jim said, known bug.

We will be making new exporter releases in the coming months to address this and other problems, and to add features as well.

If you know of specific problems or have feature requests, please drop me an email.


Development Lead
Windows Graphics & Gaming Technology

Share this post


Link to post
Share on other sites