Archived

This topic is now archived and is closed to further replies.

adam17

Weird Linking Errors

Recommended Posts

adam17    227
okay im compiling lesson 27 and im getting a weird problem. the program compiles and runs the FIRST time. the second time if i compile it and then link it (seperately) the compiler says "linking..." and then stops. vc++ just freezes. i have let it go on for hours and nothin happens. is there a corrupted file any where? i have tried to reinstall it multiple times and nothing seems to fix it. does anyone know if there is a registry file or some small corrupted file thats making this happen?

Share this post


Link to post
Share on other sites
ZealousElixir    256
What version of VC++ are you using?
What are your system specifications?
Does VC actually freeze, or does the build process simply stop (i.e. does the program respond in any other way)?
Have you checked for patches to your version of VC?
Have you tried compiling with a reduced number of background programs?

It''s unlikely that anyone would be able to tell you what file/key might be corrupted, since corruption occurs rather randomly. Since you''ve reinstalled, this seems unlikely anyway.

Best of luck,
ZE.

//email me.//zealouselixir software.//msdn.//n00biez.//
miscellaneous links

Share this post


Link to post
Share on other sites
adam17    227
VC++ 6
1.67 GHz Athlon, 512 PC3200 RAM, 110GB HD, GeForce2 Ti
VC freezes, there is no reply after that line. in fact the cursor continues to flash. i try to close VC but it says it was in the middle of compiling and i have to wait.
i have service pack 6 installed
yes i have tried with fewer bg programs.

this is really weird because i have tried compiling and linking NeHe''s OGL basecode and i still get that problem.

Share this post


Link to post
Share on other sites
ZealousElixir    256
This is the point of the troubleshooter you always reach, having answered all the questions it asks you, and finding that no one has ever had that problem before (or so they seem to think, when in reality it''s the most common issue: a generic one).

Sorry I couldn''t be of more help. Hope someone comes along who can provide better info.

Peace,
ZE.

//email me.//zealouselixir software.//msdn.//n00biez.//
miscellaneous links

Share this post


Link to post
Share on other sites
stefu    120
I remember having occasional freezed some year ago whe I used VC6, but only occasionally. I don''t know what was the reason.

Try reinstalling everything Should work on Windows

Share this post


Link to post
Share on other sites