Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

TechnoCore

big yellow... problem

This topic is 5555 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

big yellow square polygon filling between 20-100% of my screen when i go to fullscreen. It does this with some c++ /directx programs. For example if I use the Dx9-wizard in vc6++, and just choose to it to make a single triangle, the yellow polygon is there covering most of the screen, but only when i go into fullscreen. It fills from the bottom and up abit on the screen. What could possible be wrong ? Has my gfx-card had it ? I have a geforce1, win98...

Share this post


Link to post
Share on other sites
Advertisement
Hmm...sounds odd. I''ve been programming in DirectX for about 2 years on a whole lot of platforms and I''ve never seen the described problem, especially DirectX 9! Maybe its your drivers? Are you clearing the z- and color-buffers? All that mish mash housekeeping? Thats all I can think of... Hmmm, one more theory: when you use the vertex buffers, are you filling the entire buffer (or rendering only bits you''ve filled)? Sometimes, I''ll render a few vertices which I''ve not touched, and a quad with vertices as +-#INF cause some big problems... Good luck!

Chris Pergrossi
< ctoan >
My Realm

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!