Archived

This topic is now archived and is closed to further replies.

Ortho/Perpective Texture Display

This topic is 5326 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, I have an odd problem, im creating an editor, with 3 orthographic viewports, and one perpective viewport, these two varietys of viewport use the same rendering code, and access the same polygon soup, so all the tex coords etc are the same, but the textures only display in the perspective viewport. Does anyone have any ideas why this might be so? Thanks [edited by - LowCalorieSoftDrink on May 8, 2003 1:59:28 PM]

Share this post


Link to post
Share on other sites
check where u do this:
glEnable(TEXTURE_2D), glDisable(TEXTURE_2D)

______________________________
My Website: <link src="http://www.antondev.tk">
or directly at http://home.attbi.com/~antonweb/
"I''ve read about...doom being used to manage unix programs(you "kill" the processes)" dede

Share this post


Link to post
Share on other sites
*sigh*

im not a newbie, i know how to use GL_TEXTURE_2D

i guess it is just a simple mistake, but perhaps not that obvious, thanks for the suggestion anyway.

http://apengine.theobtuseangleofdewm.net/Screenshots/Large/APEditor3.jpg

[edited by - LowCalorieSoftDrink on May 9, 2003 9:20:53 PM]

Share this post


Link to post
Share on other sites
I did not intendt for u to think that u r a newbie, it was the only suggestion I had .......

______________________________
My Website: <link src="http://www.antondev.tk">
or directly at http://home.attbi.com/~antonweb/
"I''ve read about...doom being used to manage unix programs(you "kill" the processes)" dede

Share this post


Link to post
Share on other sites
There is no specific texture mapping for orthographic or perspective view.

The picture looks like there is no rasterization at all, not just that the texture disappeared. Do you render in wireframe when in orthographic view ? Do you setup an alpha channel ? Do you enable backface culling ?

Share this post


Link to post
Share on other sites
i have to agree with vincoof. it looks like u''re rendering in wireframe mode and/or ur faces are reversed with backface culling enabled. or is it?

Share this post


Link to post
Share on other sites