Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Wendigo

OpenGL Error in exit of OpenGL program..

This topic is 5532 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

the program works good, but in the exit, the DEBUG WINDOWS of visual C+ 6.0 shows this: Loaded ''C:\WINNT\System32\ntdll.dll'', no matching symbolic information found. Loaded ''C:\WINNT\system32\OPENGL32.DLL'', no matching symbolic information found. Loaded ''C:\WINNT\system32\msvcrt.dll'', no matching symbolic information found. Loaded ''C:\WINNT\system32\KERNEL32.DLL'', no matching symbolic information found. Loaded ''C:\WINNT\system32\ADVAPI32.DLL'', no matching symbolic information found. Loaded ''C:\WINNT\system32\rpcrt4.dll'', no matching symbolic information found. Loaded ''C:\WINNT\system32\GDI32.DLL'', no matching symbolic information found. Loaded ''C:\WINNT\system32\USER32.DLL'', no matching symbolic information found. Loaded ''C:\WINNT\system32\glu32.dll'', no matching symbolic information found. Loaded ''C:\WINNT\system32\ddraw.dll'', no matching symbolic information found. Loaded ''C:\WINNT\system32\dciman32.dll'', no matching symbolic information found. Loaded ''C:\Archivos de programa\Logitech\MouseWare\system\LgWndHk.dll'', no matching symbolic information found. Loaded ''C:\Archivos de programa\Archivos comunes\Logitech\Scrolling\LGMSGHK.DLL'', no matching symbolic information found. Loaded symbols for ''C:\WINNT\system32\Msvcp60.dll'' Loaded ''C:\WINNT\system32\version.dll'', no matching symbolic information found. Loaded ''C:\WINNT\system32\lz32.dll'', no matching symbolic information found. Loaded ''C:\WINNT\system32\nvoglnt.dll'', no matching symbolic information found. Loaded ''C:\WINNT\system32\mcd32.dll'', no matching symbolic information found. The thread 0x4F4 has exited with code 27 (0x1B). The program ''D:\util\opengl\GL1\Debug\GL1.exe'' has exited with code 27 (0x1B). Thanks at all in advance.

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
That is standard debugging output....not an error

Share this post


Link to post
Share on other sites
The first several lines are just telling you which DLLs were loaded, and if their symbols (function names, etc, for debugging) were loaded or not).

The only kind-of odd thing in that list is an exit code of 27. The exit code is the value you return from WinMain when it exits, and should be the wParam of the WM_QUIT message, which comes from the value passed to PostQuitMessage(). Is there a reason you''re passing 27 to PostQuitMessage?

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!