Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

antareus

Interop debugging sucks

This topic is 5533 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

This is the second worst debugging experience: managed/unmanaged debugging (worst debugging experience would be gdb). Debugging unmanaged code from a managed application takes on order of 2-3 seconds to complete almost any debugger action, rendering the debugger useless. I''m running on a nice machine: 2.66ghz P4, 1gig of RAM, and VS 2003. Anyone dealt with this? I''d be interested to see if there was any way to speed this up. I feel really bad for my coworkers now if this is what they use.

Share this post


Link to post
Share on other sites
Advertisement
I don''t have any direct experience here, but one thing to check is how it is looking up the debug symbols. That can slow down debugging a lot in normal apps if it keeps looking for symbols and can''t find them.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!