Archived

This topic is now archived and is closed to further replies.

small texture, large on screen

This topic is 5310 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I tried a few things for this, but haven''t been able to get it work correctly. I''m making a sky as a flat plane at the moment (tho I might upgrade to a dome), with a single texture on it (with clouds). The problem being that the texture doesn''t tile, and therefore needs to be projected onto the entire plane. But the texture is 512x512, and it gets ''pixelated''. What setting should I alter in OpenGL to ''blur'' the texture when it gets rendered? I haven''t been able to find the setting.

Share this post


Link to post
Share on other sites
I think I already tried that, but will check.
I also changed the GL_....._MIN_FILTER to GL_....._MAG_FILTER (not sure what is was exactly, and don''t have the code at hand) where the texture is created. Also without effect.

Share this post


Link to post
Share on other sites
Use GL_LINEAR_MIPMAP_LINEAR, GL_LINEAR_MIPMAP_NEAREST, or GL_NEAREST_MIPMAP_LINEAR followed with a call to gluBuild2DMipmaps or use the GL_SGIS_GENERATE_MIPMAP extension.

I don''t have a signature

Share this post


Link to post
Share on other sites
It may be smarter to render the texture, tiled. What I did, was I split the entire quad up into 4 quads and textured each one using a *tileable* texture. This way, you can set independant effects to one of the four quads, like lightning. And it also solves the pixelating problem.

Share this post


Link to post
Share on other sites