Archived

This topic is now archived and is closed to further replies.

Sphax

60 FPS max ?

Recommended Posts

Hi every body, I'm writing litle apps to teach myself OpenGL, using Glut (may be my problem has nothing to do with glut, but it's just an information . The maximum FPS i can get even with an empty scene is approximately 60 FPS. If i make my main loop a litle bit slower, my frame rate drop to 30 FPS. I was thinking it has someting to do with vertical sync, but when disabling this from the drivers settings, no changes ... Have you got an idea ? I forgot : I've an AMD 1600 with a GeForce 3, i'm sure it can do much better than 60 FPS Sphax [edited by - Sphax on July 2, 2003 12:59:10 PM]

Share this post


Link to post
Share on other sites
I''m quite sure my frequency is 60Hz (can you change this when running Ogl app in fullscreen ? a recent post tends to say no, unless you download an evil application i don''t whant to use ), and i agree with you that the drop to 30 FPS is probably due to vsync.
So i have disabled vsync in the drivers settings (from the desktop properties), and i still have the same problem .

I''m running under Windows XP , no one have experienced the same problem ?

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Right click desktop, click Properties->Settings->Advanced->Monitor

then adjust the refresh rate here.

I''m using Windows XP Pro and it might be different for you. Don''t know OpenGL, but it is a vsync problem. My solution will just increase your framerate from maybe 60 fps to 100 fps and probably isn''t exactly what your looking for.

Share this post


Link to post
Share on other sites
Myopic : no, i didn't try that, cause i didn't know it was possible. Thank you, i'll shearch the way to do it.... May be you can help me ?

Anonymous poster : Oh i have tried this also (and also my refresh rate is never 60hz, it hurts my eyes ) , but when you run Ogl in full screen, it seems to swap to 60 Hz ...

[edited by - Sphax on July 2, 2003 1:42:31 PM]

Share this post


Link to post
Share on other sites
If you''re using WinXP, the Nvidia cards experience a bug where they''re limited to 60Hz. You can circumvent this by using a utility such as NVrefresh or something similar. This allows you to set your Nvidia card to any mode that is allowed by your monitor.

Hope it helps.

Share this post


Link to post
Share on other sites
quote:
Original post by TheLastZerg
If you''re using WinXP, the Nvidia cards experience a bug where they''re limited to 60Hz. You can circumvent this by using a utility such as NVrefresh or something similar. This allows you to set your Nvidia card to any mode that is allowed by your monitor.

Hope it helps.

It''s no bug sucka. And I don''t think it''s just nvidia cards either.

Anyways, I use NVRefresh and it fixed my refresh rate in both D3D and OGL, so I must recommend it to the OP.

Share this post


Link to post
Share on other sites
second thread that i dont understand.. what do you all mean with openglfullscreen? opengl doesnt have a real fuyllscreenmode, you just make a bordelesswindow maximized, and if you want to change resolution you does that with win32 calls, and in that call you set the frequency as one of the parameters.. you dont need a tool to write 100 in that option.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
of all the game programming job postings on places like monster.com, dice.com, etc, the framerate they ask you to be able to maintain is 60 FPS. this isn''t helping you solve your problem, but I''m just saying 60 FPS is fine.

Share this post


Link to post
Share on other sites
Anonymous : You''re right, 60FPS is fine, but i think the maximum FPS you can reach is a good "indicator" (don''t even know if this word is english, i just translated it from french ) of your app''s performances, no ?


MazyNoc : You''re probably right too. I found something interesting with glut, the function glutGameModeString and glutEnterGameMode wich allows you to choose the resolution and the refresh rate of your screen. At home, with my Windows XP pro and GeForce 3 card, even if you choose 100 Hz and the call to those functions is successfull, i STILL have a 60 max FPS .
At work, under W2000 with an ATI card, i can really set the refresh rate to 100 Hz and so a 100 FPS ...
I don''t know if it''s a glut problem (probably not) , a windows problem or a video card one. The best way to eliminate glut is to make my window directly with win32 calls, i''ll see the difference ...


PS : the problem isn''t my home screen, it can perfectly reach 100Hz

Share this post


Link to post
Share on other sites
It is a problem with windows 2000 and XP, limited by default to 60Hz.

In windows you can change the resolution, bpp and refresh rate with the function ChangeDisplaySettings. I don''t think this can be used in GLut.

Share this post


Link to post
Share on other sites
Ok, here we go.

If you use vertical sync then it syncs!
Hard?
Let say that the monitor is 60Hz then the output fps you can get is 60, 30, 15, 7.5, 3.75 and so on
Turning off vsync gives you more fps but is it good?
Well, I would aim for 60 fps and use the rest of the time for better lighting, higher resolution and so on.
But the easy way out is always to turn off vsync.
This done by setting the updating delta to 0.

Share this post


Link to post
Share on other sites
bullshits,the problem lies in GLUT not in anything else.With a simple teapot(from GLUT) drawn my win app drops down around 550 FPS.why don''t you simply write a windows or linux app.It''s really easy...

"You losers better learn...NOONE CONTROLS OUR GOD DAMN LIFE!!!" - MANOWAR

Share this post


Link to post
Share on other sites
That''s exactly what i''m going to do . Even if perf''s don''t increase, i prefer avoiding the use of such libs (glut or SDL), so every bug will be my own bug . But they are really great when you begin to learn Ogl.

Share this post


Link to post
Share on other sites