Archived

This topic is now archived and is closed to further replies.

Problem adding functions in .NET

This topic is 5272 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, This has been frustrating me all day, I''ve never seen it happen before and can''t find any info on the net about it, I was wondering if it has happened to anyone else. What happening is when I right click on a class to add a function in VC++.net, I get the standard add function dialog, and I add in all the info to create the function, but when I click on create, .net throws up an dialog saying "object required" and will not add the function to the class, I have tried it with several classes and sometime it comes up and sometimes it doesn''t. it seems very random and is kind of annoying. Any ideas?

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Well, what''s happening is the IDE is running script to manipulate your source file. To find out exactly what''s going wrong, you can simply run another instance of VS.NET and attach to the first one (be sure to turn on trapping of exceptions).

Most likely it''s because the file was modified in a way that the script can''t handle.

Personally I think it''s a time sucker and not a time saver to use the IDE to do things like adding methods to classes....

Share this post


Link to post
Share on other sites