Archived

This topic is now archived and is closed to further replies.

Problem when moving project to .NET

This topic is 5277 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

i recently converted a project im working on from vc6 to .net. now when ever i run the program i get an error: #include <windows.h> #include <GL/GL.H> #include <GL/GLU.H> #include <GL/GLAUX.H> #include <fstream> #include <string> #include <memory> #include <stdio.h> #include <stdarg.h> #include <fcntl.h> #include <vector> using namespace std; that tells me that there is a missing ; before using. i think it has something to do with the gl includes. can ne1 help

Share this post


Link to post
Share on other sites
Change your include list from

#include <windows.h>
#include <GL/GL.H>
#include <GL/GLU.H>
#include <GL/GLAUX.H>
#include <fstream>
#include <string>
#include <memory>
#include <stdio.h>
#include <stdarg.h>
#include <fcntl.h>
#include <vector>
using namespace std;

to

#include <windows.h>
#include <GL/GL.H>
#include <GL/GLU.H>
#include <GL/GLAUX.H>
#include <fstream>
#include <string>
#include <memory>
#include <cstdio>
#include <cstdarg>
#include <cfcntl>
#include <vector>
using namespace std;

(Note that all .h include files have been changed so that the .h is removed and a c is added as a prefix. This is the new ANSI standard)

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
its the gl headers im sure when i take em away i dun get htat error nemore, but of course i get another thousand

Share this post


Link to post
Share on other sites