Archived

This topic is now archived and is closed to further replies.

PlagueViper

Problem when moving project to .NET

Recommended Posts

PlagueViper    122
i recently converted a project im working on from vc6 to .net. now when ever i run the program i get an error: #include <windows.h> #include <GL/GL.H> #include <GL/GLU.H> #include <GL/GLAUX.H> #include <fstream> #include <string> #include <memory> #include <stdio.h> #include <stdarg.h> #include <fcntl.h> #include <vector> using namespace std; that tells me that there is a missing ; before using. i think it has something to do with the gl includes. can ne1 help

Share this post


Link to post
Share on other sites
biovenger    122
Change your include list from

#include <windows.h>
#include <GL/GL.H>
#include <GL/GLU.H>
#include <GL/GLAUX.H>
#include <fstream>
#include <string>
#include <memory>
#include <stdio.h>
#include <stdarg.h>
#include <fcntl.h>
#include <vector>
using namespace std;

to

#include <windows.h>
#include <GL/GL.H>
#include <GL/GLU.H>
#include <GL/GLAUX.H>
#include <fstream>
#include <string>
#include <memory>
#include <cstdio>
#include <cstdarg>
#include <cfcntl>
#include <vector>
using namespace std;

(Note that all .h include files have been changed so that the .h is removed and a c is added as a prefix. This is the new ANSI standard)

Share this post


Link to post
Share on other sites
VolkerG    151
Have you treied, what header file causes the error?
Try to comment out some of them, until that certain error is gone.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster   
Guest Anonymous Poster
its the gl headers im sure when i take em away i dun get htat error nemore, but of course i get another thousand

Share this post


Link to post
Share on other sites