Archived

This topic is now archived and is closed to further replies.

hello2k1

Very simple

Recommended Posts

Sorry... but I''ve changed the names of my classes/functions for my physics engine that it''s starting to annoy me. Could someone please tell me what the name for a push/pull force is? Right now my engine is broken down like this: Velocity->Angular Velocity Acceleration->Angular Acceleration (What goes here?)->Torque Thank you

Share this post


Link to post
Share on other sites
Compression is the opposite of tension, and are used for distinguishing push from pull, but I think Force still fits a lot better.

Share this post


Link to post
Share on other sites
velocity and angular velocity are analogs,
acceleration and angular acceleration are analogs,
momentum and angular momentum are analogs,
and force and torque are analogs.
From a purely dimensional standpoint, force is the right word. Force and torque represent the exact same amount of specific-ness; just as there are push and pull forces, there can be push and pull torques.

[edited by - vanillacoke on July 9, 2003 9:03:01 PM]

Share this post


Link to post
Share on other sites
I agree with some of the others here. Just use Force. If a particular way of interacting with an object either pushes or pulls, you can perhaps give that instance of Force a name, such as CharacterPushingForce or CharacterPullingForce that would be added together with all other forces to calculate the total force on the object. But these are game-specific uses of the general-purpose Force. I just don''t like the idea of putting game-specific names into your engine that presumably you might want to use later for an entirely different type of game that doesn''t have the same type of specific forces.

Graham Rhodes
Senior Scientist
Applied Research Associates, Inc.

Share this post


Link to post
Share on other sites