• Advertisement

Archived

This topic is now archived and is closed to further replies.

Simple VC++ 4.0 Problem, please help

This topic is 6454 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

THIS SITE ROCKS!!!! Before I got into GL, I thought I should at least see if I can compile the code. I made all of the bools uppercase. I included opengl32.lib. The compile went fine, but two link errors came up. --------------------Configuration: Lesson2 - Win32 Debug-------------------- Compiling... Lesson2.cpp Linking... Lesson2.obj : error LNK2001: unresolved external symbol _gluPerspective@32 Debug/Lesson2.exe : fatal error LNK1120: 1 unresolved externals Error executing link.exe. Lesson2.exe - 2 error(s), 0 warning(s) ________________________ Can someone tell me why these errors are occurring. I suspect that it is because my opengl32.lib is old. As the subject states, I am using Visual C++ 4.0 standard edition.

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
You want to make sure that your libraries are linked in your project in Visual c++.

Go under Project/Settings/Link/Object-library modules and make sure you have the following libraries added to the list of linked libraries.

opengl32.lib glu32.lib glaux.lib

That should solve your problem

ernie
timpreager@home.com

Share this post


Link to post
Share on other sites

  • Advertisement