Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

deathtrap

problems setting up SDL

This topic is 5541 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I'm having some trouble setting up SDL on Windows using Visual C++ 6.0 . In debug build i keep getting the following errors: Linking... msvcrt.lib(MSVCRT.dll) : error LNK2005: _exit already defined in LIBCD.lib(crt0dat.obj) msvcrt.lib(MSVCRT.dll) : error LNK2005: _strncpy already defined in LIBCD.lib(strncpy.obj) msvcrt.lib(MSVCRT.dll) : error LNK2005: _fclose already defined in LIBCD.lib(fclose.obj) msvcrt.lib(MSVCRT.dll) : error LNK2005: __isctype already defined in LIBCD.lib(isctype.obj) LIBCD.lib(crt0init.obj) : warning LNK4098: defaultlib "msvcrt.lib" conflicts with use of other libs; use /NODEFAULTLIB:library SDLMain.lib(SDL_main.obj) : error LNK2001: unresolved external symbol _SDL_main Debug/SDLinstallationTest.exe : fatal error LNK1120: 1 unresolved externals And in release build, the following errors: Linking... sdlmain.lib(SDL_main.obj) : error LNK2001: unresolved external symbol _SDL_main Release/SDLinstallationTest.exe : fatal error LNK1120: 1 unresolved externals I've set up everything, including the lib and include directories. EDIT: managed to get it to compile correctly in release build, but in debug build it's still giving errors, the same errors. [edited by - deathtrap on July 26, 2003 2:51:34 AM]

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!