• Advertisement

Archived

This topic is now archived and is closed to further replies.

DX9 -> DX7

This topic is 5290 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

i use DX7 part of the DX9 SDK package. i wonder if my application can operate on windows 2000 and XP when i use DX7 code ?? hope that my question is clear enaugh, with my poor english thanks

Share this post


Link to post
Share on other sites
Advertisement
thanks BlackGhost. DX7 has been designed for windows 2000 and before, and not for XP, isn''t it ?

xaxa, originally i used ddraw and d3dim. with DX9, d3d.lib doesn''t exist anymore. therefore i use d3d9.lib and ddraw.lib simultaneously. it works properly, but SDK documentation tells it''s not a good thing to use ddraw and d3d9 together...

Share this post


Link to post
Share on other sites
It''s not a good idea to use DX 7 and 9 _together_, but you can of course use either one, provided they are installed.
New DX releases always include the old versions as well.

Share this post


Link to post
Share on other sites

  • Advertisement