Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

GekkoCube

polygonal shimmering sideeffect.

This topic is 5554 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

when my water surface intersects with my terrain, i get that "shimmering effect" which looks terrible. the edge of the water and terrain (where they meet) is not smooth, but rather fuzzy, or just scratchy looking. im thinking this is the z-buffer issue, but turning it on or off doesnt make a difference. i also tried increasing the polygon count of the water, still no difference. anyone know how to fix this without covering it up (like with trees).?

Share this post


Link to post
Share on other sites
Advertisement
Draw the water last and turn off the ZWRITE renderstate - _not_ the ZBUFFER renderstate.

Share this post


Link to post
Share on other sites
i do disable ZWRITE.
and i dont swee why drawing the water last would make a difference.

what if i disabled culling when i draw the water too?

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!