Archived

This topic is now archived and is closed to further replies.

FIXED!!: Help request!(FreeBSD) Just installed, won’t boot.

This topic is 5238 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi there I’ve a small confusion, well problem really. I’ve Installed FreeBSD 5.0-RELEASE (from the CD-ROM that comes with the book `FreeBSD Unleashed (second edition)` and The install seemed to go fine (each time, I’ve reinstalled I think 4 times now). However when I get done installing and try to do the initial boot all I get (after the boot menu, at which I press F5) I all I get is something like: “Stage 1” with a solid square block char and an `a`(I think) with a squiggle on top (squiggle looks like a 7, sorta..). That is all it does (perhaps I’m not letting it sit long enough?),… far as I can tell it hangs right there. I’m confused and would really appreciate comments/suggestions!
quote:
Boot process sorta looks like this: Boot Menu: F1: ???? ???? F5 Drive 1 (I press f5) Stage 1 SXX
(with the X’s being the odd chars) (This is from memory and I’m a touch tired; might have boggled it about a bit.) Thank you! Feral *edit: damn italics tag!* [edited by - FeralOfFiretop on August 10, 2003 11:39:46 AM] [edited by - FeralOfFiretop on August 11, 2003 6:02:01 PM]

Share this post


Link to post
Share on other sites
2 Drives (both maxtors)


  1. Drive 1 -- 30gig


    • Primary Drive (Primary master I think, ATA)

    • MBR has FreeBSD's boot loader

    • 30gig partition


      • Win2k

      • NTFS file system

      • don't want to touch this drive save for MBR



  2. Drive 2 -- 20gig


    • Slave (Primary slave, I think, ATA)

    • MBR -- blank, or default... NONE during Freebsd install anyway.

    • 10gig partition (first on drive)


      • FreeBSD

      • / -- 256meg (pretty sure)

      • /tmp -- 256meg

      • /var -- 256meg

      • /home -- 7gig

      • /swap -- 1.4gig (have 768megs ram)


    • 10gig partition (rest of drive)


      • Fat32 file system

      • Ment as a way of transfering files between FreeBSD and Win2k; also doubles as a handy backup space)





The FreeBSD partitions were made via the automatic option in the lable editor.

Once the initial boot hanged as described, I loaded up the cd and got sysinstall running.. I noticed that the mount points for the FreeBSD partitions on the FreeBSD slice were missing.; I've no idea if that is normal or not.)

Thank you for your help C-Junkie!

*edit: clarification*

[edited by - FeralOfFiretop on August 10, 2003 7:58:08 PM]

Share this post


Link to post
Share on other sites
I am not sure I understand what I just saw.

Popped in the (FreeBSD install) CD and got sysinstall running again and selected post install configuration.

The Label editor let me select between two disks 0 and 1. Now as I understand it I’ve FreeBSD installed on 1 (i.e. second hard drive, the 20gig one), however in the label editor there are NO mount points (“”) This vexes me. On a whim I went to disk 0 (presumably the 30gig with win2k) ... an I found my mount points! I am confused.

Both disk 1 and disk 2 seem to be showing the second hard disk.

Soo, looks like …. I don’t have a clue


Any and all help appreciated!

Share this post


Link to post
Share on other sites
indeed.

sounds like somethings a bit messed up. Where are all the FreeBSD experts here, anyway?

As I recall, the FreeBSD bootloader is pretty simple. It searches the table for partitions marked bootable, checks their fs type, and guesses based on fs type what OS is there, and lets you jump to the bootloader present in the partition-level boot area (rather than the mbr)

So the ''???'' could be expected if it didn''t know NTFS. But the ''Disk 1'' is interesting. Any FreeBSD expert want to say if that''s referencing the partition on disk 1, or the disk 1 mbr itself?

If its the mbr, you could try having the cd install on the disk1 mbr also. see if that helps at all...

Share this post


Link to post
Share on other sites
As it happens I tried just that (placing the FreeBSD bootloader in disk 1''s MBR)... with no (visible) effects.

Hum, wonder if the boot loader is confused. Or, perhaps if FreeBSD isn''t compatable with my hardware someplace down the line. (Trying to figure out why the lable editor sees disk 1 twice... it didn''t do that at install time (i.e. seemed fine/proper).)

Wacky

Share this post


Link to post
Share on other sites
Ok.

I believe the mount points don''t show when you run it after install. At least I''ve never seen them. Just leave them be, they''ll still have their labels when you boot if you don''t change them.

Did you set your FreeBSD slice as bootable? You should see an "A" in your Flags when you go to your FDISK Partition Editor of your second disk (probably ad1 if you have Atapi IDE).

Int.

Share this post


Link to post
Share on other sites
Also, you might want more room on your root partition, or better yet, make a decent sized /usr partition. /usr will hold almost every application you install, including X, as well as all your ports, packages and distfiles.

I would probably go and split your home up a bit unless you really need 7Gs at home..(MP3s? MPEGs? *grin*).

Int.

Share this post


Link to post
Share on other sites
Aaaaah! I did NOT set my FreeBSD slice as bootable!! Indeed that is what it was, Golly that's silly easy!

Woot!

:happy dance : (think snoopy)


So, I've got a working BSD system now! (woohoo!) X works (WindowMaker currently), mouse works (in X, though I still need to get the mouse wheel working)

One thing that nags at me thought is it seems a bit sluggish, slow disk access...


On a funny note, got loged in and typed `vi` ... Golly, it's actually VI! (I've never seen vi before, it's always been vim impersonating vi) Luckily I installed vim 6.1 when I installed bash, sudo and a few (small) other things. (= Fun fun fun!

Thank you both very much for your help and input!

I've layed my drive out like so:
ad1s2a / 256M UFS1
ad1s2b swap 1515M swap
ad1s2d /var 256M UFS1+S
ad1s2e /tmp 256M UFS1+S
ad1s2f /usr 4096M UFS1+S
ad1s2g /home 3859M UFS1+S
ad1s1 <none> 9299M dos
(= You know, I've no idea where /usr would have gone with the other layout,
heh.

Now, assuming I don't break something as I move in... (=

Thank you both again! (and anyone else who would have helped if they coulda )


[edited by - FeralOfFiretop on August 11, 2003 5:49:52 PM]

Share this post


Link to post
Share on other sites
No problem, it occurred to when I saw your drive layout.

usr would have been placed in / if you didn''t create it. The default is if the directory doesn''t on a mount point, you''ll get it under /. BSD is very strict to using /usr and /usr/local for applications, you''ll find everything gets installed there, so always plan it with some space.

What exactly do you feel is causing sluggish disk response? Is it an application you''re running?

You might want to see if there are any tuneable parameters or kernel patches for your disk controller. Usually a search for your controller type in dmesg will give you enough info for a google search.

You can use iostat to learn more about your disk usage.

''iostat -d -w 1'' will display disk stats at repeating 1 second intervals. You could also use ''systat -iostat'' which will display a console graphic to show you disk usages.

See how much MB/s you get while working with files.

BSDs used to smoke Windows and Linux for perfomance, now its marginal or maybe slightly behind Linux with defaults ( I think a fully tuned FreeBSD can run as a server faster than linux, but its nothing to make a complete decision over in most cases). To be honest, you have to have a high-availability, heavy-load application to even both with comparing performance on such low levels in my mind. Odds are your slow feel to disk performance is specific apps or perhaps (unlikely) a driver bug.

Bear in mind that FreeBSD 5.x is currently considered testing and you''ll find bugs.

You might want to patch up your ports collection, or maybe your "world". Though you might want to read up on all that before you dive in, especially if you just want to play around. I think they''re planning a stable version of 5.x branch (maybe 5.2) in the fall, I would just hang tight then upgrade when it comes out.

Best tip I can give is to use find in the ports collection before you install anything. Odds are someone already created a port. =)

I usually ''cd /usr/ports'' and then ''find . -name "". Then you can just head into that directory and ''make clean install''.

If you don''t want to compile, you can download packages from ftp.freebsd.org.

Let me know if you see any weird reboots with X. I got one at work, but I haven''t tried or wanted to pin it down yet. Only happens on these Dells we got for client machines.

Int.

Share this post


Link to post
Share on other sites
I''m not sure it is just disk access or what..

I havn''t put my finger on it yet.. it is almost as if I''m not getting alot of cpu time or something.


Fwiw, vim for instance is quite slow (subjective I know) as well.
There is a noticable delay in the vim window showing up as well as just not being very responsive (slow in taking keys, slow in redrawing screen, etc.). Almost as if I''m connected remotly or something. (reminds me of logging into an old bbs at 2400baund )

I grabbed two logs of ''iostat -d -w 1'' activity, the first was with ''startx'' with windowmaker not setup right (got vanilla x, no wm at all.. *shrug*). The second was after kde (finally ~15min at a guess) loaded and I finally got a term window open. Loaded kview and a picture.. never did get a file manager open (it said it loaded, but nothing ever showed up... similar to what happended with root, save those eventually showed up as I shutdown). .... It is very wierd. (slow graphics redraw as well, but I figure that is just the current nv driver (default ones from XF86). On a related note Gnome2 complains about bonobo and basically does not work. Really doubt there is any relation to the sluggishness though.

Anyway summery of iostate:
X-load: (ended up with vanilla X)
Count: 51
AVG 0.053921569
Max: 0.72
Total: 2.75
(p.s. This was the fastest I''ve seen X showup, X''s startup messages are normally onscreen for a while.. they flashed by this time... no idea.)


InKde:
Count: 362
AVG 0.006657459
Max: 0.22
Total: 2.41

To me the max MB/s looks really low but I''ve no idea.
Count is the number of samples taken (at 1sec intervals, of course)

As for ports and such... Aye! Can''t say I dislike how BSD does things so far... the port of clanlib is waaay out of date though (I have not connected to the net yet with it so I''m not sure if I''m stuck with vim 6.1 for a while or if the vim 6.2 will work with my bsd release .. I''m a touch confused on that still.)

Anyway so far so good, just have to figure out how to get it to go faster now, heh

Share this post


Link to post
Share on other sites
Doesn''t look like your disk is under much usage, either that it is so buggy you''re not even going over 2MB/s =). This is doubtful though.

You could check to see if anything is eating up your CPU. Run ''top -S'' and then when in top, type ''o'', then type ''cpu'' and hit enter. This will sort your process list by cpu usage. Idle should be in the high 90''s most of the time, unless you''re running something with CPU demands. You could also use the graphical perfmon in X. I usually use Gnome, it''s in System Tools in the menu I think. If you poke around you can find it.

You might want to check your X performance. Do some searches for your Video card, see if they have their own native linux drivers. You could also make sure you X setup is properly using extensions and such.

Try a quick run with ''glxgears'' in X. This will run a window for a while, displaying fps.

You can also run ''glxinfo''. This will give you a lot of information about your cards openGl support. You can also find a line early on saying "Direct Rendering Yes" (or will say no). This will let you know if you''re using the DRI extension.

As for the newer ports, you could update your ports. You can look at www.freebsd.org and head to the handbook, look up Cutting Edge or something similar.

Int

Share this post


Link to post
Share on other sites
Fwiw I was getting 17kbs during install off cd for alot of the time during instilation of kde/gnome2 and dependancies (gaah that took a while). ... cd went from 170kbs~ at the high (only saw it once I think) to a probable average of 50kbs ... lots of pauses like it was clearing cash or something, it was not a constant transfer, anyway...

My controler I do believe:
atapci0: <VIA 82C686 ATA100 controller> port 0xd000-0xd00f at device 7.1 on pci0

It looks like whatever is irq11 is eating half my cpu time... I certinaly hope that isn't normal ... idle time (assuming I'm reading it right) never went about 1% while I was looking at it.).

For good measure I'm including an abrevated 5 (dan I forget the term).. well 5 frames anyway of top (`top -Socpu -d5` if I recall right)


PID USERNAME PRI NICE SIZE RES STATE TIME WCPU CPU COMMAND
21 root -68 -187 0K 12K RUN 8:03 49.37% 49.37% irq11: dc0 ac
7 root -84 0 0K 12K actask 2:13 11.23% 11.23% acpi_task2
6 root -84 0 0K 12K actask 2:13 11.18% 11.18% acpi_task1
5 root -84 0 0K 12K actask 2:13 10.69% 10.69% acpi_task0
19 root -28 -147 0K 12K WAIT 0:11 10.64% 10.64% swi5: acpitas
11 root -16 0 0K 12K RUN 0:20 0.93% 0.93% idle
38 root 171 52 0K 12K pgzero 0:04 0.00% 0.00% pagezero

PID USERNAME PRI NICE SIZE RES STATE TIME WCPU CPU COMMAND
21 root -68 -187 0K 12K *Giant 8:04 48.88% 48.88% irq11: dc0 ac
7 root -84 0 0K 12K actask 2:13 11.62% 11.62% acpi_task2
6 root -84 0 0K 12K actask 2:13 11.18% 11.18% acpi_task1
5 root -84 0 0K 12K actask 2:13 10.74% 10.74% acpi_task0
19 root -28 -147 0K 12K WAIT 0:11 10.50% 10.50% swi5: acpitas
11 root -16 0 0K 12K RUN 0:20 1.03% 1.03% idle
38 root 171 52 0K 12K pgzero 0:04 0.00% 0.00% pagezero

PID USERNAME PRI NICE SIZE RES STATE TIME WCPU CPU COMMAND
21 root -68 -187 0K 12K *Giant 8:05 48.78% 48.78% irq11: dc0 ac
7 root -84 0 0K 12K actask 2:14 11.67% 11.67% acpi_task2
6 root -84 0 0K 12K actask 2:13 11.28% 11.28% acpi_task1
5 root -84 0 0K 12K actask 2:13 10.84% 10.84% acpi_task0
19 root -28 -147 0K 12K WAIT 0:11 10.40% 10.40% swi5: acpitas
11 root -16 0 0K 12K RUN 0:20 1.03% 1.03% idle
38 root 171 52 0K 12K pgzero 0:04 0.00% 0.00% pagezero

PID USERNAME PRI NICE SIZE RES STATE TIME WCPU CPU COMMAND
21 root -68 -187 0K 12K *Giant 8:06 49.12% 49.12% irq11: dc0 ac
7 root -84 0 0K 12K actask 2:14 11.43% 11.43% acpi_task2
6 root -84 0 0K 12K actask 2:13 10.99% 10.99% acpi_task1
5 root -84 0 0K 12K actask 2:13 10.89% 10.89% acpi_task0
19 root -28 -147 0K 12K WAIT 0:11 10.40% 10.40% swi5: acpitas
11 root -16 0 0K 12K RUN 0:20 1.03% 1.03% idle
38 root 171 52 0K 12K pgzero 0:04 0.00% 0.00% pagezero

PID USERNAME PRI NICE SIZE RES STATE TIME WCPU CPU COMMAND
21 root -68 -187 0K 12K *Giant 8:07 49.27% 49.27% irq11: dc0 ac
7 root -84 0 0K 12K actask 2:14 11.23% 11.23% acpi_task2
6 root -84 0 0K 12K actask 2:14 10.84% 10.84% acpi_task1
5 root -84 0 0K 12K actask 2:14 10.79% 10.79% acpi_task0
19 root -28 -147 0K 12K WAIT 0:11 10.79% 10.79% swi5: acpitas
11 root -16 0 0K 12K RUN 0:20 1.03% 1.03% idle
38 root 171 52 0K 12K pgzero 0:04 0.00% 0.00% pagezero

(hopefully the fourm didn't murder that pretty output )

I did not get to try glgears yet. card is a (MSI) NVIDIA GeForce 4 Ti4200 ... I've already DLed NVIDIA's FreeBSD drivers but have not got around to installing yet (docs say I'll have to recompile kernel, haven't got that far yet (want to get connected to net first and (possibly) cvsup before hand.. assuming it is safe at the time.) )




Thank you for your help Interim!

p.s. Sidenote: Heh they way I type you'd think I'd like lisp, all those nested Prens and such.
*edit: cursed be the angle brackets for html doth eat them! ... BAH!*

[edited by - FeralOfFiretop on August 12, 2003 11:04:10 PM]

Share this post


Link to post
Share on other sites
No worries.

Looking at your top outputs, I think ACPI is interfering with your system. I haven''t played with it much, personally have never seen this before, but its eating up most of your resources. There is probably a bug somewhere with it.

I bet the irq process is from that as well.

For kicks and giggles, try ''acpiconf -d'' to disable acpi. I don''t think that will work, you might have to add a line to your /etc/device.hints file.

Edit /etc/device.hints and add the line ''hint.acpi.0.disabled=1''. Probably easiest to reboot after this, ''shutdown -r now''.

Check your top or ps again after the reboot to see if its still eating your CPU (betting it won''t). If this isn''t a laptop, then you probably don''t need it (just no sleep mode), but you can then look for fixes to ACPI (must be a known bug) or you can switch to APM.

Int.

Share this post


Link to post
Share on other sites
Ahhh!
Yup, looks like that evil ACPI was behind it all!
‘acpiconf –d’ did work, at least somewhat… it took out the irq11 one and gave me 70% or so idle time, as I recall. So I went about disabling acpi! (as this is a desktop system I’ve really no care about acpi in the first place, and certainly not if it is giving me trouble ) By the by this is a athalon 900 768meg ram, in case anyone was curious

I found that ‘/etc/device.hints’ didn’t exist, so I created it and after a ‘shutdown -r now’ found that nothing had changed... So after some reading/googling I was pointed to ‘/boot/device.hints’ added ‘hint.acpi.0.disabled="1"’ at the bottom and after another shutdown no trace of acpi now and 99.8-100% idle time! Yay!

So, now that speed is where I was expecting (fast!) I’ve got to figure out how to get kde ||&& gnome working right! (gnome doesn’t seem to have bonobo... and kde seems fine for root but normal login won’t load the file manager. (‘mutex error - device busy’ as I recall) Really not sure there but haven’t looked very well yet so hopefully I’ll trip over something

How does one go about setting permissions for a mount point? My /windows mount is set as ‘rw’ in the options column in ‘/etc/fstab/’ but only root has write permissions. ... ‘man mount’(?) mentioned that the mount has the permissions of the current location or something like that, i.e. ‘/’ … I’d like all of wheel (group: seems easiest?) to have rwx access.

Fwiw I don’t seem to have much installed yet... no glgears for instance.

Woot, getting close to being usable now!

Share this post


Link to post
Share on other sites
Oops, my bad. Sorry about that, it is /boot/device.hints. I guess I was on crack this morning. Sorry to get you on a side trip.

As for the mount point, you can just make sure its set for root:wheel = ''chown root:wheel /windows''. Then make sure its read-write for the owner and group. You can do this with ''chmod ug+rwx /windows'' or ''chmod 774 /windows''.

You should probably rerun /stand/sysinstall and reselect all the X window components for KDE and GNOME before you spend too much energy on that one.

Int.

Share this post


Link to post
Share on other sites
(: Not a problem at all, keeps me on my toes!

/windows (which is a mount_msdosfs, spcifically fat32 dos partition) is owned by root:wheel, but it does not want to allow write access to the group, even ''chmod g+w /windows'' did nothing .. assuming I understand it (chmod) right that is `make /windows writable by group`... so that should have done what I wanted. still drwxr-r- though (from memory); normal (wheel group) login gets permission denied, of course. I did not try ''chmod 774 /windows'', but that is the same exact thing as ''chmod ug+rwx /windows'', assuming I understand it right

I ran `/stand/sysinstall` (didn''t know it was there! been just sysinstall, from /usr/sbin/) and discoverd bonobo (among a few other things) were um... how do we say this... not checked. Heh. So, installed all the gnome things and it croked on hostname, of which I''m looking up now, I beleve I just need to put ''hostname 127.0.0.1'' in `/etc/rc.conf` (I think `man hostname` said).

I don''t understand what you mean by `...reselect all the X window components for KDE and GNOME...` ... as in uninstall/reinstall?

Thank you bunches!
p.s. 600-700kps off the cdrom now, lol.

Share this post


Link to post
Share on other sites
Try ''umount /windows'', then do ''chmod ug+rw''. Then ''mount /windows'' (since you have it defined in your /etc/fstab.

Yes, I don''t the install in front of me. But there is a selection to install the X components. It''ll reinstall/install those things you missed.

Yeah, you can just add your hostname to your /etc/hosts to solve that X problem. It should still load though. Add a new line (leave localhost) that uses your assigned IP.

Int.

Share this post


Link to post
Share on other sites
Neato...
I set `hostname="localhost"` in `/etc/rc.conf` and as `/etc/hosts` already contained entries for localhost it would seem that is all I need do; at least so far as gnome2 is concerned. I’m not sure at all if I’ll have to set that differently once I get connected to the `net with it.

Anyway Gnome2 seems to work now... installing bonobo and setting hostname seems to have done the trick there. KDE’s file manager now works with my normal name as well... turns out it was keeling because (or at least something to do with) sound preview and given that I have no sound (SoundBlaster Live! Value, which as I understand it has experimental drivers at this stage... as such I’ll worry about sound later). Anyway went to the control panel thing and turned off all the preview options (file was the problematic one) and was able to load konqueror and turned off the sound preview and all seems well.

Sooooo, now on to figuring out how to properly configure/run kde/gnome. Also in the queue is conecting to the net! (I never had any luck connecting linux to the net so if I’m lucky I’ll be able to post from konqueror at some point in the future )

So far so good! (:
p.s. ahh that is reasonable, change permissions when it(/windows) is not mounted! How reasonable! (: (:
p.p.s I don''t think I would have gotten this far without your help Interim, thank you VERY very much!

Share this post


Link to post
Share on other sites
No worries, little slow at work. Besides, you need to pass on the help at least once in return as you settle in.

What you did will fix it, but I would set your hostname to something you like. Then go to /etc/hosts and add a line with your new hostname and your ip address.

So say you have a private network running 192.168.1.0/255.255.255.0 and you''re on 192.168.1.2. Add ''192.168.1.2 ''. Gnome and KDE will find your hostname from there.

If you start using your machine as an FTP server, or web server, you''ll probably have to populate your hosts file with all your local network machines to speed up connections (you''ll see initial logins to FTP are slow, since I believe TCP Wrappers will try to resolve the IP a few times for logging). You''ll also need to change the BSD default, which is to try DNS, then hosts file. Otherwise you''ll still get the long delays. All you have to do there is copy /usr/compat/linux/etc/nsswitch.conf /etc/nsswitch.conf. You might also want to edit that file and change the line ''hosts: files nisplus nis dns'' to ''hosts: files dns nisplus nis''.

I never tried getting the SoundBlaster Live! running, but I know it works. I bet a simple google search with FreeBSD 5.0 and SoundBlaster Live! will return steps on how to do it.

You should stop by
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/index.html

That is probably one of the better overviews of running BSD (and even Linux for some topics). It also covers common things you''ve seen and want to do (setup PPP for dialup, or set up firewall services). That combined with man pages will get you upto speed.

Its time consuming at first, but once you learn a good set of the Unix tools and design, you''ll be able to move along and get productive. BSD is nice in the sense they have several elements that centralize management. Sysctl, /boot/device.hints, /etc/rc.conf. With RedHat, I used to alter boot scripts, scrounge around to find where they set variables or what files they want to read for settings. When I first used BSD I was pleasantly surprised to find all the common system administration tasks centralized. Once you learn those tasks and how to do them effectively, you''ll find its much more consistent than some Linux distribution.

You might also want to look into making sure Linux compatibility is running on your system, also covered in the Handbook in detail. It does a great job of running Linux binaries with little to no issues or overhead. I run my Matrox video Linux drivers on FreeBSD using Linux compat. This may help with commerical software not compiled on BSD you still want to use from Linux.

G''luck with the rest of it. Hope you enjoy the change =)

Int.

Share this post


Link to post
Share on other sites
I was going to try and answer this from KDE, but looks like it will be a while before I figure out that modem stuff. (Luckily USR has a linux.rpm for the modem so there is at least hope.)

So anyway,

I think I have my hostname and such right now, have my computer named a900 which matches what I call it in windows so I’m happy there (a900 for athalon 900, basic but functional naming scheme!)... sound card should be a kernal recompile as I understand it, and that is not looking so bad. Seems to be a pretty intelagent design as far as kernal recompiling goes, but I’ve really on scratched the surface so far.

It’s nice and fast, pretty, functional, choices(!) and all in all I’m really pretty happy so far. I’m by no means to a working, usable system yet but (need net and a lot of ports/packages; get kde&&||gnome setup, etc.) but what I have seen I like a lot, and that is saying something.

I am quite surprised you can run linux vid drivers though, I’m starting to think the as fast as linux isn’t an exageration which is pretty nice, to say the least. (I’ll probably have to do that for my modem, which works for me)

Other than that I’ve got the single html of the handbook offline and I’ll be able to reference that so mayhaps I won’t have to drop out (and back to win2k - where the modem works) and google as much.

(: So far so good, and fun too!
:bow
Feral

Share this post


Link to post
Share on other sites