Archived

This topic is now archived and is closed to further replies.

BGCJR

Stencil Shadow Demo

Recommended Posts

~420 FPS in fullscreen mode
~285 FPS in windowed mode

System: intel p4 1400 mhz
256 mb
geforce4 ti 4200 + 128 mb

like Austrian Coder, it crashes in FS mode when exiting.

Share this post


Link to post
Share on other sites
Different Computer, now it works.

Windowed : 85 fps (1280x1024)
Fullscreen: 140 fps

Athlon XP 2800+
GeForce 4 Ti 4800 SE
1024 MB DDR-333

Probably crashes: You do not test if a computer supports the extensions you''re using (blending?).

/Other computer was a Laptop
/P3 500
/ATI Rage Mobility-P AGP
/256 MB

Share this post


Link to post
Share on other sites
Great, the initialize crashes on the older cards and the others need the lastest drivers!
Nvidia has 4.5.2.3 out yesterday!

the end crash must need DeInitializing of VBO.


Game Core

Share this post


Link to post
Share on other sites
60fps (vsync limited) windowed and fullscreen. GF3, P4/1.5G, WinXP.

Oh, cool demo BTW. I've been looking for some easy-to-understand stencil shadow stuff, without loads of extra features that complicate the matter.



[edited by - Kippesoep on August 15, 2003 3:29:35 PM]

Share this post


Link to post
Share on other sites
Um, it doesn''t crash, but i''m sure it''s not displayed right. I see a beast in the middle, but it''s yellow!! This can''t be right!! I can rotate it and move it, but I don''t think it''s ment to be solid yellow!
btw, i get 300fps and I''m on a radeon9500, athlonXP2500, 512RAM, with windows XP and catalyst3.6 drivers.

Am i missing a texture file? The zip i downloaded only contained lesson1.exe and a data folder containing test69.bsm.

Share this post


Link to post
Share on other sites
yep, it''s a stencil shadow demo, with two lights.
still optimizing it and trying to figure the problem with ATI video cards.
Lesson 27 works and my VBO works cause you see the monster.
but i don''t know why the stencil buffer is not displaying on ATI.

I looked for docs and demos w/ source but no luck finding the problem.

Bobby

Share this post


Link to post
Share on other sites
Very nice, I get 125fps windowed (1.2GHz Duron, Geforce 4 MX 440) but it crashes in fullscreen mode.

Hyperdev

"To err is human, to really mess up requires a computer"

Share this post


Link to post
Share on other sites
Lukerd: I like that scene from LOTR TT contest entry, i would love to see it shadowed!
Maybe, I''ll look up the specs, anymore info and screenshots?

Bobby

Share this post


Link to post
Share on other sites
I'd love to see it shadowed too, infact that was the plan, but i'm running outta time coz I have to go away, so my demo has to be in a week early and I dont have time to shadow it now. I'm actually having to cut about 3 scenes competely. Here's a screenshot of my version of the Bauul Model



Lukerd.

Hyperdev

"To err is human, to really mess up requires a computer"

[edited by - Lukerd on August 15, 2003 9:13:14 PM]

Share this post


Link to post
Share on other sites
Thanks, the demo isnt that great (its my first one) there''s still alot i''m not happy with. BTW i''ve added a link to your site on my page. Keep up the good work with the model editor.

Hyperdev

"To err is human, to really mess up requires a computer"

Share this post


Link to post
Share on other sites