Archived

This topic is now archived and is closed to further replies.

bilsa

FPS ?!

Recommended Posts

Hello! Ok... I've been doing some Direct3D lately, and now I feel I'm ready to give OpenGL a chance and then decide which to go for. So, I checked out NeHe's tutorials and some projects there. But the dissapointment so far is actually stunning... In the codesnippets in tutorial 1-5 i'm not sure but I think I get about 20-25 fps and in tutorail 6 I prolly get less than that, since the cube is lagging its way in its orbit... So, now to be really sure if there is a problem with my drivers or if OpenGL is that stinky I'm asking you guys!? (I duobt it's OpenGL... otherwise you wouldn't stick to it right ?!?!) So... for eg, a textured and rotating cube with Direct3D gives me about 280 fps. But the same in the OpenGL lesson 6 gives me about 20 fps ?! Same goes for the "Textured Beam" example on the NeHe site. (that one almost crashes my system...) So... tell me it's a joke or something? (I haven't started with the coding yet... just downloaded some examples for inspiration...) My system: Duron 1ghz 384mb SDRAM 32mb GeForce2 GTS Win XP So could there be some sort of driver compatibility issue? Someone tell me it's a nightmare! (Otherwise the NeHe site is the most impressive resource on OpenGL... probabilly the most impressive on 3D ^^) [edited by - bilsa on September 1, 2003 5:21:18 PM]

Share this post


Link to post
Share on other sites
Hello!

I got kind of the exact same problem. I started coding openGL some weeks ago. I''ve noticed that my fps is constant at 70 when running window mode and about 50 when using fullscreen.

At first I really didn''t care but now after trying all my code in Linux and saw that my fps was between 1000-1500 fps I figured somthing must be really wrong with my *something* in windowsXP.

My system is:
Athlon XP1600+
512MB DDR
64MB GeForce4 TI4200
WinXP Pro

Now I hope someone could give us a solution to this problem!!

(Excuse my bad english... from Sweden )

Share this post


Link to post
Share on other sites
Hello again!!

Now I have found the soulution to at least my problem!!
I asked a friend who is a big time gamer :D and he gave me this link:

http://www.libsdl.org/pipermail/sdl/2001-September/038859.html

So uncheck the V-sync option and the fps is up at 1400 :D

I hope that is the soulution to your problem as well! good luck!

Share this post


Link to post
Share on other sites
I actually find that with vsync disabled its slightly more jerky because the frames that are actually displayed are not evenly spaced from each other. The only advantage disabling vsync does is allowing for faster/smoother input which I don''t think is nearly as important as smooth graphics.

Share this post


Link to post
Share on other sites
Actually... my problem is not with the vsync... since i dont even get 30 fps. I have an average of 6 fps in different kinds of demos that i have downloaded.

I will try reinstall my graphic cards drivers today... maybe that will help.

Note that I haven''t coded anything myself yet...

Share this post


Link to post
Share on other sites
quote:

Release, not debug, debug is much slower!



Come on, he''s just displaying a cube.

Bilsa: use glGetString(GL_RENDERER) and check if you get "GDI Generic". In which case you''re running in software mode.

Install the latest NVidia drivers.

Profile the code. Check which function call is slowing you down.

Y.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Are you using the latest graphics card drivers? I had the same problem with my GF2mx, until I realised that all along I was just windows generic GF2 drivers. The minute I put in the Hercules drivers for my card, the frame rate shot up tremendously (and so does the number of supported OGL extensions, which is from another of NeHe''s tutorial).
My guess is that the generic drivers support hardware acceleration for DirectX, but only software rendering for OGL.

Share this post


Link to post
Share on other sites