Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Toolmaker

HTTP request through a proxy server

This topic is 5462 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am currently developing a simple application which tunnels through a Novell BorderManager proxy server. However, it returns a 400: Bad Request page. As a simple test I decided to request the index.html on my own webserver. This is the request I send to the proxy server:
strcpy(buff, "CONNECT toolmaker.homeip.net:80 HTTP/1.0 \r\nGET /index.html HTTP/1.0\r\n\r\n");
send(s, buff, strlen(buff), 0);
[code]

What is wrong with this?

Toolmaker   

-Earth is 98% full. Please delete anybody you can.

Share this post


Link to post
Share on other sites
Advertisement
Try leaving out the connect part and sending the full path to the proxy...


GET http://toolmaker.homeip.net:80/index.html HTTP/1.0
Host: toolmaker.homeip.net:80

Share this post


Link to post
Share on other sites
Gotta try that tomorrow since I don''t have a proxy server here.

Toolmaker



-Earth is 98% full. Please delete anybody you can.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!