• Advertisement

Archived

This topic is now archived and is closed to further replies.

DirectDrawCreate error using Dev-C++

This topic is 5252 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I''m just trying to write a bare-bones Win 32 app using DirectDraw and I keep getting the same error:
Compiler: Default compiler
Executing  g++.exe...
g++.exe "C:\Dev-Cpp\Projects\DirectDraw Test\main.cpp" -o "C:\Dev-Cpp\Projects\DirectDraw Test\main.exe"    -I"C:\Dev-Cpp\include\c++"  -I"C:\Dev-Cpp\include\c++\mingw32"  -I"C:\Dev-Cpp\include\c++\backward"  -I"C:\Dev-Cpp\include"  -I"C:\DXSDK\Include"   -L"C:\Dev-Cpp\lib" -L"C:\DXSDK\Lib"
C:\DOCUME~1\BLAKEY~1\LOCALS~1\Temp/ccI3baaa.o(.text+0x235):main.cpp: undefined reference to `DirectDrawCreate@12''

Execution terminated
 
I get the same error when I try to use DirectSoundCreate(). I''ve included all the necessary files I think (ddraw.h and windows.h) so I don''t know what''s up. I''ve gone to Tools->Compiler Options->Directories and added C:\DXSDK\Lib and C:\DXSDK\Include to the Lib and Include directories, respectively (along with all the directories that were already there like C:\Dev-C++\Lib and \Include). I''ve also tried adding them via the Project->Project Options->Directories method, but I still get the error. Any help is appreciated.

Share this post


Link to post
Share on other sites
Advertisement
have you actually added the libs to your project in project options?

are you using the correct dxsdk(the one available on the dev-c++ site)?

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
Hi, I tried using Dev C++, but I thought it was very hard to get every thing right, (or maybe I just didn''t know enough Direct x ), if you still have a hard time with it try and get visual c++ 6.00 (.net would be a fortune), even the student edition will be enough, especially while if you''re still learning. All I had to do was link the lib and the includes files in the sdk, and it''s worked every time. I haven''t got a lot of money, I got mine on ebay,

Share this post


Link to post
Share on other sites

  • Advertisement