• Advertisement

Archived

This topic is now archived and is closed to further replies.

Standard Library Problems

This topic is 5244 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

When i try to use libraries like and wwhile i am making big applications like games it never seems to work. I get the error "String used as type but not defined as type" or "ostringstream blah blah" i know there is a linking problem , but it only when i link to opengl libraries because i when i make a console application the libraries work fine... ios there ne way to conquer this/

Share this post


Link to post
Share on other sites
Advertisement
You''re going to have to post the actual errors, and the actual code which caused them. There''s nothing about OpenGL or windows applications to stop you from using the STL.


How appropriate. You fight like a cow.

Share this post


Link to post
Share on other sites
It could be that you are including headers in the wrong order. Try making sure that gl, windows and STL headers are all included before any of your own headers.

Geocyte Has Committed Suicide.

Share this post


Link to post
Share on other sites
ok thanx for that... the actual code i am using are any windows or opengl inialization funcitons. I am just receiving an error, not that it isn''t linking properely but things like string and ostringstream are not types, (when i use the string and sstream libs)

Share this post


Link to post
Share on other sites
POOOOST your COOOODE.


How appropriate. You fight like a cow.

Share this post


Link to post
Share on other sites

  • Advertisement