Archived

This topic is now archived and is closed to further replies.

DakeDesu

Blackbox not working

Recommended Posts

Well, I am trying the whole blackbox thing again--and it is not working quite right. (please note that the computer that is being worked on is nowhere near where I am right now) I type: blackbox, and I get the an error like ''BaseDisplay::BaseDisplay undefined'' (or something extremely similar). Another error message I get when trying to run blackbox is "$DISPLAY not set" After getting that error, I tried typing "echo $DISPLAY" and funnily enough, it was not set. Though after reading through XServer, Xdm, and a few other man pages, is that $DISPLAY is not set until after X11 is started. So I try type ''startx'' and then in the console it gives me in twm, ''blackbox''. It gives me a screen locking error. So I read through some more Xwindows man pages, looking for a way to have blackbox startup with Xserver. So I try ''xinit -- blackbox :0'' and various variations of that, and keep getting errors like: ''unable to connect to Xserver,'' and ''No display surface set in X11Config.'' Which I ran a couple X11 config scripts, and found that the server was perfectly fine the way it was setup (except for an error with the mouse).
Member of the Shove Pouya Off A Cliff club, SPOAC. If you wish to join, add these two lines to your signature ------------------------------------------------------------ DAIAGA Dave Astle is a God Association. To join, put this in your sig! [ Got Immortality? ] [ Home page ] [ Evil Twin ] [ Jargon File ] [ Politics Forum ] Projects: [ Game Developer Man ] [ Variables ] [ YearNeo/VariaML ] [ Daytanea ] [ Gnu-Com: Alien Research ]

Share this post


Link to post
Share on other sites
The server is fine.

''.xinitrc'' in you''re home directory is not. that script is run when you use ''startx''. if you do not have a ''.xinitrc'' in your homedirectory, then you''re using the systemwide one. somewhere in /etc, like /etc/X11/xinit/xinitrc or something. anyway, if is is NOT in your homedir, try this

cd
echo "exec blackboc" > .xinitrc
chmod 700 .xinitrc
startx

see if that starts blackbox for you.

Share this post


Link to post
Share on other sites
Thanks--it is working now.

Any idea of how to get the monitor settings to change resolution, or colour depth? That is my only quip left with Blackbox.


Member of the Shove Pouya Off A Cliff club, SPOAC.
If you wish to join, add these two lines to your signature
------------------------------------------------------------
DAIAGA Dave Astle is a God Association. To join, put this in your sig!
[ Got Immortality? ] [ Home page ] [ Evil Twin ] [ Jargon File ] [ Politics Forum ]
Projects: [ Game Developer Man ] [ Variables ] [ YearNeo/VariaML ] [ Daytanea ] [ Gnu-Com: Alien Research ]

Share this post


Link to post
Share on other sites