Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Vivanco

Particle Texturing problem

This topic is 5385 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey all, I have recently implemented a particle system into my 3D engine, I adapted code from NeHe. The particles are created using Triangle strips, then textured. The problem is when I combine the particle engine with my terrain generation and skyboxing the particle textures are messed up. It doesnt seem to bind the particle texture(you just see the blank particles). If i dont render anything but the particles it works fine. Somehow my textures from the skybox and terrain and getting mixed up with the particle textures. Has anyone had a similar experience, or know of what the problem might be? Any help would be great, thanks. (o)..A Bee bit my bottom, now my bottom Big..(o)

Share this post


Link to post
Share on other sites
Advertisement
Possibly you are using texture that have been binded before for multi-texturing??

make sure you do
glBindTexture(GL_TEXTURE_2D, 0);
before rendering your particle systems

Share this post


Link to post
Share on other sites
I''m also having a problem very similar to this, it''s for a university assignment. I''m using display lists generated from a max 3ds file by a standalone exporter, which exports straight into OGL code.

I have asteroids and a spherical starscape made up of object lists, but anything I try and put in myself loses it''s textures, even though I''ve gone through and tried to figure out where it''s happening, I can''t see it.

I''ve removed any call to glDisable(GL_TEXTURE_2D), throughout both the object lists and the rest of my program, I''ve set glBindTexture(GL_TEXTURE_2D, 0) before rendering anything else, but it still ends up with the last used texture (in my case, the stars).

Pretty, but not much use!

Any help would be greatly appreciated, I''ll post code up if it''s asked for!

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!