Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

AIRmichael

Multiple render passes causes artefacts on ATI

This topic is 5438 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hey, I have a problem with multiple render passes. I use glDepthFunc(GL_LEQUAL);. It seems that it works fine on NVidia cards, but on ATI cards artefacts can be seen. That means lines/dots nearby the camera that vanishes/popups while looking around. How can that be fixed? Greetings, Michael L. [edited by - AIRmichael on October 24, 2003 1:08:56 PM]

Share this post


Link to post
Share on other sites
Advertisement
Woooo dude, I think you have the syntax of the function wrong. glBlendFunc takes 2 paramateres for instance: glBlendFunc(GL_SRC_COLOR, GL_ONE). I''m not sure why yours even compiled. Try looking up the syntax in the MSDN library on microsoft''s site or whichever you use, but hey if one parameter works I''d be suprised.

Share this post


Link to post
Share on other sites
Sorry, glDepthFunc(GL_LEQUAL); it is. If it was blendfunc with 1 parameter it wouldnt even compile hehe.

[edited by - AIRmichael on October 24, 2003 1:10:13 PM]

Share this post


Link to post
Share on other sites
how about depthfunc = GL_EQUAL?..




If that''s not the help you''re after then you''re going to have to explain the problem better than what you have. - joanusdmentia

davepermen.net

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
This usually happen when your zNear is 0 or lower. you have to use at least a zNear of 0.1

Share this post


Link to post
Share on other sites
Known for their poor precision? I think you are very much mistaken. Both ATi and nVidia run at the same precisions (16/32 bit colour, 16/24 bit depth buffer), ATi has 24bit floating point math in fragment programs whilst nVidia has 16bit and 32bit (and is far slower).

I can do multipass rendering just fine on ATi cards, with better results than my previous nVidia card gave. What are your near and far clipping planes set to?

Share this post


Link to post
Share on other sites
Just try to use the texture matrix and scroll x or y position by a large number.
Any value above 128 or below -128 should do, but try 10000 to be sure

You''ll get weird lines on an ATI, and magnification seems to fail - but no problem on my gf3.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!