Archived

This topic is now archived and is closed to further replies.

texture scaling in Direct3D

This topic is 5140 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I would like to know how to disable min/mag filtering for my textures. I really do want a texture to scale up and look jagged, like if you render a 32x32 texture to 320x320 part of the screen, you should be seeing a bunch of 10x10 blocks of pixels, not smoothed at all. This has got to be possible, but all the sampler states I tried did not work. Thanks.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
If your gfx card control panel has a "force anisotropic" setting, make sure it''s turned off because i''ve seen it force bilinear filtering.

Share this post


Link to post
Share on other sites
Anisotropic filtering is OFF in my control panel.

I want an old school pixelated look to my game. There has got to be a way.

And point sampling is the default, which gives the same blurry effect as the rest.

[edited by - foofightr on November 7, 2003 10:44:08 AM]

Share this post


Link to post
Share on other sites
I just don''t get it. I''ve polled D3D caps and the card does support point-sample magnification (as all cards should, I believe). I''ve checked that anisotropic filtering was turned off in the control panel. I''ve told D3D to use point sampling for min/mag, even though the docs say it''s the default.

But textures are still blurred...

Share this post


Link to post
Share on other sites