Archived

This topic is now archived and is closed to further replies.

Can't find include files

This topic is 5151 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I have just installed the DirectX 9.0 Update SDK.exe (184 Mb) and I just can''t compile any examples made in C++ because VS.NET 2003 can''t find the reference to d3dx9.h (and others DirectX header files). ex.: VS.NET 2003 always return a bug on this line #include <d3dx9.h> Does anyone know how to fix this thing? You think a minor thing like the end of the world was gonna do me in?

Share this post


Link to post
Share on other sites
may sound stupid but you have told Visual Studio the directories to the DX9 SDK includes/library files?

sometimes you have to tell it the directory yourself, and make sure its the top of the list aswell...it sometimes doesnt like being anything other than top...silly microsoft..lol

Share this post


Link to post
Share on other sites
1) Go to the Tools->Options menu

2) From the options, select Projects->VC++ Directories

3) Select "Include files" from the "Show directories for:"

4) Add the path to the DX SDK include files to the list (e.g. "C:\DX90SDK\Include"). Ensure that path is at the **TOP** of the list.

5) Do the same for Library files (the path will be something like "\DX90SDK\Lib").



--
Simon O''Connor
3D Game Programmer &
Microsoft DirectX MVP

Share this post


Link to post
Share on other sites
Goddamn it! This is the most silly thing I''ve ever seen... At least, it''s working now. Thanks! :D

You think a minor thing like the end of the world was gonna do me in?

Share this post


Link to post
Share on other sites