Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Blowin

VC++ debugger weird behaviour

This topic is 5309 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi all, I am developing an MFC application with vc++ 6.0. The app should load a vrml model and then a text file with some data regarding the model. The model isn''t always the same one, it is chosen from the final user. Now, the problem is that sometime a memory access violation exception is raised. It occours always with the same models. The weird thing is that when i debug the application (F5), no exception is raised and the app works very nicely, using all the data retrieved from the files (model + informations). So, 1. i know the data are correctly loaded because the app use them; 2. i don''t know where/why the exception is raised since in debug mode everything is ok. Have you any clue/suggestion? Thanks you all, B.

Share this post


Link to post
Share on other sites
Advertisement
I''ve had situations like that arise. It usually happens when something is time dependent. For your case, the function that loads the model may start a thread and you are trying to manipulate that data before it is actually loaded.

Share this post


Link to post
Share on other sites
yes, i guess so.
or maybe it can be a memory overrun. memory overruns seems don''t occour in vc++ debugger.

any idea how can i trace the error since in debug run there are no probs?

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!