Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

vicviper

very weird problem with DirectSound, help!!

This topic is 5361 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hi, I have a really weird problem with my DirectSound wrapper (dx9): whenever I play a 3D sound alone (no other sounds or music playing in the PC) the sound plays ok but when I am streaming music, or even hearing some music direct from CD with media player in another thread, whenever I play a 3D sound, the volume of the streaming channels (winamp mp3, media player CD, whatever) is set to max for the time the 3d sound is playing. so, figure I am hearing some music with media player at half volume, and then, I run my app: when I play a 3d sound, the volume of the music I''m hearing is set to maximum for a few seconds. weird, uh? how can avoid this to happen, any help??

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!