Archived

This topic is now archived and is closed to further replies.

why do I get kicked out of a game on linux fedora??

This topic is 5175 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I will be playing any game on linux from terminal or not, and in about 15-20 minutes it will just boot me out and make my screen super large. Then I can''t see where I move my mouse and have to reboot. It does not come up with any error messages so I am not sure how to go about fixing it. I am using Fedora 1 and Nvidia drivers 4496 if that matters any... Thanks

Share this post


Link to post
Share on other sites
What games in particular? I''ve run a couple of simple ones without any problems on fedora core 1 using nvidia drivers. The games were gltron and gl-117. I can try to duplicate your problems.

Share this post


Link to post
Share on other sites
Oh yeah, I forgot about the simple games...well those work fine. But games like Chromium, Tux Racer, Wolfeinstine Demo, and Neverwinter Nights. Basically all the really good 3D games..

On Chromium, it always seems to happen on the 3rd boss. I don''t even see the 3rd boss, it just kicks me out.

On Neverwinter Nights, it seems to happen when I go into a room.

Tux racer, it just happens random, usually after a while of playing.

Wolfeinstine, it just happens randomly too. Sometimes I can play it for a while and other times it seems to boot me out.

Have no idea why this is happening either

Share this post


Link to post
Share on other sites
Sounds like your video drivers are messed up in some way related to 3D acceleration. What video card is the machine using and with what drivers? Did Fedora set up the video-related stuff or did you change anything manually?

Share this post


Link to post
Share on other sites
I am using an MSI Ti4200 128mb with the latest nvidia drivers which are the 4496''s (NVIDIA-Linux-x86-1.0-4496-pkg2.run). No, Fedora did not do any of it for me..

I installed them by:
logging in as root

then:
sh NVIDIA-Linux-x86-1.0-4496-pkg2.run --extract-only
cd NVIDIA* # NVIDIA-Linux-x86-1.0-4496-pkg2.run
export IGNORE_CC_MISMATCH=yes
export CC=gcc
make install

that went well, then I changed my XF86Config by changing the nv to nvidia.

Then I added more screen resolutions and added more hz so it wasn''t only 60hz with 640x680 or whatever it was.

And this is a fresh install of Fedora besides the beta''s so there arn''t any RH8 and RH9 pieces of code sitting in the config file(I checked for those anyway)


I know the drivers are working though because I get the splash screen and the games play...so im not sure. Maybe I messed up when I installed the drivers.

Share this post


Link to post
Share on other sites
when you say "make my screen super large" is that because it's changed to some lame resolution like 640x480? in which case you can press ctrl-alt-+ to cycle through you resolutions to get back to what you want to be in.

as for the crashes i would guess it could be to do with the "export IGNORE_CC_MISMATCH=yes" line. i assume you set this because it gave you an error about using a different compiler to compile the driver from the one that compiled the kernel (this caused problems for a friend of mine). the only thing i would suggest is to recompile your kernel with your current version of gcc etc and then when you compile the driver they will be from the same compiler version and there won't be a problem. but like i say that's my guess so maybe someone else might have another idea.

edit: fixed to make sense

[edited by - necromancer_df on November 16, 2003 11:26:30 AM]

Share this post


Link to post
Share on other sites
quote:
Original post by HTML
I will be playing any game on linux from terminal or not, and in about 15-20 minutes it will just boot me out and make my screen super large. Then I can''t see where I move my mouse and have to reboot.

It does not come up with any error messages so I am not sure how to go about fixing it. I am using Fedora 1 and Nvidia drivers 4496 if that matters any...

Thanks


Remember that Fedora is still beta and hence doesn''t guaranty that anything will work as it should on it. What I recommend is that you log it in with Fedora. they will be able to try and solve your problem.


[Cyberdrek | the last true sorcerer | Spirit Mage - mutedfaith.com][ Administrator & WebMaster GuLSE]

Share this post


Link to post
Share on other sites
Well, I just tried changing the MISMATCH=no instead so hopefully that will work. Just played a few games and it seems ok, but now I have to try to get to the 3rd level in chromium to see if it really worked.

Thanks

Share this post


Link to post
Share on other sites
quote:
Original post by HTML
I just tried changing the MISMATCH=no instead so hopefully that will work

well that won''t make a difference unless there actually was a mismatch. i only assumed there was because you set that. the reason for setting that flag is because the installer will complain if you are compiling the driver with a different compiler to what the kernel was compiled with. if you set that flag then the installer won''t complain and will just do it. so if you set it to no and the installer doesn''t complain then that wasn''t the problem.

Share this post


Link to post
Share on other sites
Are there any other ways to do install them without using their setup because I cannot get that to work, and without using an rpm?

Share this post


Link to post
Share on other sites
try using
sh NVIDIA_blahblahblah --extract-only

then you get the whole source etc. and can use make directly...

Share this post


Link to post
Share on other sites