Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

two lights doesnt work

This topic is 5299 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

strange problem....it looks something like tihs... i am initializing two lights in init routine(position and color) in my drawing routine just after my rotates for mouse movements i update lights position just to rotate with everything else in the scene but one light is working and another is not...i must say that i did exactly the same with both lights and it seems that one is working properly and the other one is not...so what''s tha catch?

Share this post


Link to post
Share on other sites
Advertisement
It should, you can have up to 8 (if i remember correctly) lights at a time.

Post some init code, and what you do with the lights after the glLookat.

Share this post


Link to post
Share on other sites
Only the first light has default diffuse color (1,1,1,1)
Others are black (0,0,0,1).

Try using glLight(GL_LIGHT0 + 1, GL_DIFFUSE, ...) and give it a color like (1,1,1,1)

[edited by - baskuenen on November 15, 2003 10:14:38 PM]

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!