Archived

This topic is now archived and is closed to further replies.

SQMcquintyre

glDisable(GL_MULTISAMPLE_ARB) not working On ATi

Recommended Posts

I've been using multisampling FSAA, but disabling it with glDisable() around some text display as it just looks blurry. On a geforce 4 it works fine, but on a radeon 9700 and a 9500 the disable doesn't appear to be doing anything. Anyone got any thoughts? [edited by - SQMcquintyre on November 18, 2003 9:10:37 AM]

Share this post


Link to post
Share on other sites
Perhaps these settings are overruled by the video driver? You might want to check it out at the display settings tab.
NVidia certainly has this kind of settings that can override the settings of your program.

"My basic needs in life are food, love and a C++ compiler"
[Project AlterNova] [Novanet]

Share this post


Link to post
Share on other sites
Good idea. I had a poke around and as far as I can see there''s nothing overriding it, everything that looked like it might seemed to be set to application preference or similar.

I know that if I set multisamplesamples to 0, and multisamplebuffers to 0 that it disables FSAA on everything so it''s definitely not locked to always on.

Share this post


Link to post
Share on other sites
I just tried setting up FSAA, then immediately glDisabling it, and leaving it that way. On the gf4 the antialiasing is off, on the radeon 9700 it's on. Most annoying.

EDIT: I just found http://developer.apple.com/qa/qa2001/qa1268.html on google which mentions:

quote:
Currently, ATI graphics hardware prior to the Radeon 9800 Pro and Radeon 9600 Pro do not support the enable flag for multi-sampling, leaving it enabled in all cases. It is recommended that client correctly set the enable flag for the context as needed but not expect glDisable to be respected for certain ATI hardware.


[edited by - SQMcquintyre on November 18, 2003 1:49:31 PM]

Share this post


Link to post
Share on other sites