Archived

This topic is now archived and is closed to further replies.

I'm back with a new texture problem

This topic is 6359 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Ok, I've got another problem with textures in my openGL game. Here's a link to a picture with the problem. HERE!!! As you can see, that doesnt look to good. It's a mipmapped texture. Thanks... Edited by - Rudan on 7/13/00 4:17:32 PM

Share this post


Link to post
Share on other sites
My guess is you''re using automatic mipmap generation? What this looks like is the edges of the road texture are supposed to be blended into the grass texture, but when your program generates the mipmap the scaled down version get so blurry that the blending isn''t complete at the edges. Best solution I can think of is to handmake all the levels of the mipmap and load them in instead of relying on some kind of function to generate them for you.

Share this post


Link to post
Share on other sites
what shrinkage saiz is correct , solution do nothnk about it, this is very minor "just carry on as if this doesn''t exist","don''t waste your time on a trival thing" mate go about fixing improving someit major before u handle this. i and 100 other geezers wouldn''t of noticed this unless u brought it up

Share this post


Link to post
Share on other sites
I''m assuming that the road is another object lying onto of the grass...

I''d either:

1. Not use mipmapping for the road texture (I imagine that the road texture is pretty small anyway)

2. Only play the demo on a GeForce and have GL_ANISOTROPIC_FILTER_EXT enabled.

3. Read up on anisotropic filtering and make anisotropic mipmaps yourself. Go to http://www.sgi.com/software/performer/brew/anisotropic.html
for an overview.

Hope that helps.

Paul Groves
pauls opengl page
paul's opengl message board

Share this post


Link to post
Share on other sites