Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

kadaf

Half-Life DLLs (again :-)

This topic is 6667 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I recently asked how to compile the Half-Life DLLs with Watcom C++. Some one said I should just modify the makefiles so Watcom would be happy... ok I did, and everything compiled just nice. I was very happy, and when I discovered that the new DLLs had almost exactly the same size as the original, I was even more happy.. how cool. Then I started up half-life and my mod popped up in the list. I double clicked, and then a nasty dialog box appeared: "Unable to find DLL functions" (or similar) ARRGH!!!! I was ruined.... f*ck! I gave up doing half-life dlls. So then I tried to play a little around with DLLs. I did some DLLs which was quite nice. There was no problems using the DLL-functions through an import library... BUT when I tried to dynamically load the functions with LoadLibrary/GetProcAddress/etc when the Win32 stuff returned: Cannot find functions.... Then everything appeared very clear to me: AHA that was also why Half-Life was complaining... The point: Does anyone around know if there is any problems with Watcom DLLs?... and how to avoid these problems? thanks --------------------- Rasmus Neckelmann phudze.cjb.net

Share this post


Link to post
Share on other sites
Advertisement

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!