Archived

This topic is now archived and is closed to further replies.

Anti Aliasing

This topic is 5131 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Ive tried to implement the AA from the nehe tutorial 46. I got it to work... but dont understand the following: When I run my program, it uses the AA no matter what. Im supposed to call glEnable(GL_MULTISAMPLE_ARB); to enable it, but it works even without that. If I disable it before rendering my models it doesnt change. Ive tried to run the demo on 2 other pc''s. One didnt get any AA, and the other one only a little, but again, without really enabling it. first question: whats up with that? second q: can I set the amount of AA somehow? My vid card does 6x fine (600+ fps) but the same demo on another pc, with a ATI wonder does it with 2x or 4x (doesnt support higher) with only about 5 fps

Share this post


Link to post
Share on other sites
Check your video card settings. I know on the nvidia settings you can force allot of things regardless of what the program wants. Could be you have your card set to always have AA on. The options are something like:

Always Off
Let the application decide
Always 2x
Always 4x
etc..

Share this post


Link to post
Share on other sites
I cannot help you with your problem but why don''t you just drop Colt (the author of the tutorial) a line?
I had a question and he answered me pretty quickly and was very helpful.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
I believe that anti-aliasing has to do with the framebuffer allocation, rather than primitive rasterization. When you get an anti-aliased framebuffer, that''s probably "it" and you can''t turn it off after creation.

Share this post


Link to post
Share on other sites
quote:
Original post by Ruudje
i still havent been able to fix this... If I call glDisable(GL_MULTISAMPLE_ARB); I get fsaa anyway... its always on


iirc there is a problem with ATI''s FSAA implimentation which stops it from being disabled after its enabled.

Share this post


Link to post
Share on other sites