Archived

This topic is now archived and is closed to further replies.

Adding different X sessions in fedora "#¤%!!afgrmmp%&##"

This topic is 5130 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

why people from redhat MUST change a way how gdm checks for avaialable sessions on startup in every reincarnation of their system????? they really MUST do that with every new release?????? Shouldn''t X and using computer be EASY & INTUTIVE? well hack!!! not in redhat at least they have changed the way gdm started sessions in redhat 7, then cnanged it from 7 to 8 and then again from 8 to 9. and now they have changed it again in fedora why??????? why should it be such an important issue to change it with every release? AND NOT DOCUMENTING THAT CHANGE AT ALL!!! At least I haven''t found any docs about it. is it some kind of intelekt fight? test for IQ or revenge of too-overwored coder from redhat??? For you that doesn''t know what I''m talking about the problem is: I have several window managers installed on my system (fluxbox,afterstep,gnome, kde, xfce) and gdm shows only kde & gnome on welcome screen. With every update of gdm I had to change some scripts and paths to get all of window managers appear on startup screen so that I can choose one when logging in. It has been so with every release. I just wonder why should it be that way? Why can''t redhat at least ship some script that can find managers and update gdm itself? Or at least convert old settings. Why do I need to spend every time a few hours figuring out what they did this time? Why not at least DOCUMENT changes guys From redhat (if any of you ever reads this)????? Such idiotic cosmetic changes spoiles fun of otherwise nice system. In fedora it seems that gdm doesn''t check at all /etc/X11/gdm/Sessions path as it used to do. I had my sessions there and none of them shows on startup screen. I have also tested to move that catalog and gdm is not complaining at all !!! the question now is: how to add a session to startup screen? Where does gdm check for avialable sessions? There is also a bug there: If you change your session to twm with switchdesk (whish surprisingly shows 2 extra session for choosing - twm & window maker) and then with login choose kde or gnome; gdm will continue to log in into twm session. No matter if one change to kdm or gnome with login. First after running switchdesk again will gdm login into chosen session. To add different sessions in redhat 8 only needed thing was to add a script in gdm/Sessions catalog that will run exec your_session; I think it was very simple & nice way. In redhat 9 one should add a few scipts that will do the same thing: one should add a script in gdm/Sessions that will appear on startup screen; then a few lines in xdm/Xsession script that will call a script in switchdesk dir with name of your session. And that script in switchdesk dir did just plain: exec session_name <== really overkill - but that was the way in reinkarnation nr9. now what is the way in phedora?? If anyone knows please drop a few line below; I''m just not enough clever for fedhat X.

Share this post


Link to post
Share on other sites