Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

SHilbert

My page had been redesigned!

This topic is 6565 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
Good site! All I can say is that you''ve had a lot of time to do projects! And you''re Kurby game looks great, can''t wait to play it.

joeG

Share this post


Link to post
Share on other sites
Thanks, guys!
BTW, I'm going to write a DirectX helper library. What kind of conventions would you like it to have?
For instance...
Do_Something() vs. DoSomething()
var_name vs. VarName
Hungarian notation...?

Also, the title of this thread should be "My page HAS been redesigned.".... stupid keyboard can't keep up with my typing

lntakitopi@aol.com - http://www.geocities.com/guanajam

Edited by - SHilbert on July 17, 2000 7:36:45 PM

Share this post


Link to post
Share on other sites
hey thats a really good design! it load fast (the old one had sooooo many screen shots on its main page it was sllooow), and looks sleek..


hmmm naming conventions.....use hungarian notation if u want to use a standard otherwise
var_name and Do_Sumthing ();
(IMO )

btw-make sure you finish kirby!!!




-----------------------------
-cow_in_the_well

http://cowswell.gda.ods.org/


"If it's stupid but works, it's not stupid" - Murphey's Law

Share this post


Link to post
Share on other sites
Yeah, that's what I was thinking
I usually use Hungarian notation & mixed caps, but when I wrote these two sets of functions:
    
GetJoystickXPosition();
GetJoystickYPosition();

// and...


Get_Joystick_X_Position()
Get_Joystick_Y_Position()

It's a lot easier to see the difference.
Plus, I've spent more time worrying about which prefix to add to my variables than I have actually seen them do any good.

Also, it seems that a lot of people have read TOTWGPG as their major source, so it would be a good idea to match its naming style (same as above.)

lntakitopi@aol.com - http://www.geocities.com/guanajam

Edited by - SHilbert on July 18, 2000 10:40:36 AM

Share this post


Link to post
Share on other sites
I''ve always did it this way:

void MyClass::doSomething() { }

where the first letter of every class (unless you''re doing a data structure library like the STL ) is capitalized, and the first letter of a method is lowercase (of course there are exceptions like you''re method starts with an acronym or something like that).

I have this feeling that someone''s going to pop up from out of the blue and state that all programmers stopped doing that in the mid 80''s. Oh well, guess I''m stuck in the 80''s.

joeG

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!