Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

NihilisticMystick

weirdness in querying maximum texel units

This topic is 5328 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

This isnt really all that big of a problem, but it is a little weird. So, i was writing a little "wrapper" for openGL extension queries in the 3d engine im writing and i added the code to get the maximum texture units glGetIntegerv(GL_MAX_TEXTURE_UNITS_ARB,&numTexelUnits); anyway,before i had just assumed the texel units were 8 because im developing on my machine with a geforce FX 5900 ultra at the moment. But when i query for the texture units now it says there are only 4 texture units, but geforce FX has 8. Anybody know whats going on there?

Share this post


Link to post
Share on other sites
Advertisement
Guest Anonymous Poster
http://www.tech-report.com/onearticle.x/4782

Share this post


Link to post
Share on other sites
NVIDIA only exposes 4 texture units through the fixed function pipeline. To get more, you have to use NV_fragment_program or ARB_fragment_program.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!