Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

nagromo

lilo and cd

This topic is 5310 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I tried to add the following lines to lilo.conf: other=/dev/cdroms/cdrom0 label=cd but it gave an uninteligable error when I ran lilo. Please tell me what syntax I should use to boot a cd from lilo.

Share this post


Link to post
Share on other sites
Advertisement
OK, it turns out that I had the wrong device in /dev. Linux works with the new device (/dev/cdrom1) fine. Lilo still isn't working with it, though. When I run lilo, the last message is:

Fatal: geo_query_dev HDIO_GETGEO (dev 0x1640): Invalid arguement

It is the same error whether I have the old dev or new one in lilo.conf (even the same hex number). Before that, there are no errors. It almost sounds like it is trying to treat my CD drive as a hard drive. How can I tell it otherwise? (pardon my n00bishness...)

Here is the entry in lilo.conf:

other=/dev/cdrom1
label=CD

Do I need anything else to boot a CD with Lilo?

[edited by - nagromo on February 6, 2004 8:10:32 PM]

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!