Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

dead_parrot

Sound quality problems with Direct Music

This topic is 5422 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I''m writing a game using DirectX 8.1. The sound is done with DirectMusic, and it works fine, but after playing for a while, the sound effects become scratchy / static-y, and then they clear up again after a while. Is there something I''m doing wrong? I load the segments from .wav files and set up a 3D audiopath for them. I play them using IDirectMusicPerformance8:laySegmentEx() I also store the SegmentState data in an IDirectMusicSegmentState8 interface. If it helps, my system is a laptop with: 3.06 GHz Pentium 4 512 MB RAM 128 MB GeForce FX Go5600 40 GB Hard Drive Windows XP Home Edition Any help is appreciated.

Share this post


Link to post
Share on other sites
Advertisement
If that''s all you''re using, then any problems are problems in DX or, more likely, your sound card driver. If you were streaming on your own (locking streaming buffers, etc) then you could cause scratchiness, but not when all you do is point DirectMusic at some data and say "go".

You don''t say what your sound card is or what version of the driver you have, but I''d suggest looking for an update on your vendor''s support web site.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!