Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

mrmrcoleman

DirectX problem...

This topic is 5391 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Hello, I am using DirectShow to render an animation to a Direct3d texture and I am having trouble setting up the build environment. I have followed the SDK documentation to-the-letter as far as I am aware but I keep getting the following Linker error: Compiling... CTextureRenderer.cpp Linking... CTextureRenderer.obj : error LNK2001: unresolved external symbol "public: __thiscall BaseVideoRenderer::CBaseVideoRenderer struct _GUID const &,char *,struct IUnknown *,long *)" (??0CBaseVideoRenderer@@QAE@ABU_GUID@@PADPAUIUnknown@@PAJ@Z) Msvcrtd.lib(crtexew.obj) : error LNK2001: unresolved external symbol _WinMain@16 Debug/StarChart.exe : fatal error LNK1120: 2 unresolved externals Error executing link.exe. If anybody has come across a problem like this I would greatly appreciate some help as this is really starting to annoy me! Thanks in advance. Mark Coleman

Share this post


Link to post
Share on other sites
Advertisement
Try including dxguid.lib. Not sure if it will help you, but it fixed a similar problem I had with DirectInput.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
you need to compile the dshow base classes (they are in the sdk folder) they generate two files strmbasd.lib (for debug builds) and strmbase.lib (for release builds)

you need to link to these in your linker - or you can just do a pragma comment

#ifdef _DEBUG

#pragma comment ( lib, "strmbasd" )

#else

#pragma comment ( lib, "strmbase" )

#endif

hope that helps!

Share this post


Link to post
Share on other sites
Thank you for your input both of you, but neither works!!

I had already compiled the Base Classes, and adding dxguid.lib didnt help either!!

I have no idea what is going on now...
If anybody has any other ideas I am open to suggestion.

Thankyou.

Mark Coleman

Share this post


Link to post
Share on other sites
Guest Anonymous Poster
I had the same problem so I built all available configurations Release, debug, Unicode as added the code listed above into my dsrender.h file and it worked. THX

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!