Archived

This topic is now archived and is closed to further replies.

ECKILLER

D3D woes

Recommended Posts

ECKILLER    122
Hello, Today has been a bad day. I was dutifuly working on my 3D engine(using D3D). I just created a new class and implemented and decided to test it out. I compiled and built and executed. SCREECH! runtime error and illegal operation. Anyway to make a long story short half my source files seemed to have gotten corrupted and whats worse is D3D doesnt recognize my hardware devices anymore. They always fail during enumeration and it didn''t before i got that strange crash and my source files got corrupted. I should also mention source files in differant workspaces got screwed up to. I took out that new class i was testing and tried to recompile but it crashed again, and it was working before i had that class in. Has anyone else had problems like this. I''m really worried about why it doesnt recognize my voodoo 3. Again, It did before that program crash. Any ideas how to fix it? ECKILLER

Share this post


Link to post
Share on other sites
ECKILLER    122
Hahahahahaha...sigh. I wish it was that easy but i already tried that. Everythings still jacked up. No D3D stuff works anymore. I''m going to try some opengl apps to see if my over all video cards screwed. I did reinstall the drivers(vid card) and i did reinstall DX 7.0 and still nothing changed.



ECKILLER

Share this post


Link to post
Share on other sites
Guest Anonymous Poster   
Guest Anonymous Poster
it may be worth doing an re install of windows98(if that is what you are using) which reinstalls windows ovetr the top correcting any damaged files.This will also take you version of dx back to version 5 so you can put dx7 on again clean

Share this post


Link to post
Share on other sites