Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

DrZeiss

ODE rotation in Renderware

This topic is 5263 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am trying to fully simulate ODE in Renderware and I have a problem with trying to get an ODE''s body to sync with a Renderware frame. Here''s the situation: I have a vehicle which has 4 tire frames that are children of the main chasis. So after I move and turn the vehicle, I update the chasis with ODE''s main body and then update ODE''s tire body. The result is the tires have turned more than the main chasis. It is as though they have rotated twice (once with the body and again when I update the tires individually). BTW, I always use rwCOMBINEREPLACE so the matrix the ODE returns can be used to replace the Renderware''s frame. Can any help me figure out how I can get the tires to align with the main chasis. Thanks. Brian

Share this post


Link to post
Share on other sites
Advertisement
Yes. I have the documentation.
I think it may have something to do with my model too. Since the wheels are parented to the chasis, renderware automatically updates the wheels also. Does anyone know of a way to reset the tires'' LTM to "world identity" because I tried to SetIdentity to the tires and it ended up in the middle of the model. Anyone?
Brian

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

Participate in the game development conversation and more when you create an account on GameDev.net!

Sign me up!