Archived

This topic is now archived and is closed to further replies.

owl

(fixed) I can't turn off VSinc on Linux anymore.

Recommended Posts

owl    376
I just re-organized my linux partitions, and restored all my configuration files, reinstalled one of the lastest mesa and the NVidia drivers. Before that I was able to turn it on and of using the GL_VSINC(etc) enviroment variable (set in profile). But now, after the reinstall, this enviroment variable seems to get ignored and my game's frame rate matches the vertical refresh of the video mode I use, no mater if the variable is set to 0 or 1. Does anybody had this problem before? [edited by - owl on January 25, 2004 1:08:17 AM] [edited by - owl on January 27, 2004 11:48:39 PM]

Share this post


Link to post
Share on other sites
Null and Void    1088
Any such environment variables with the NVidia drivers are interpretted only by the NVidia drivers (the NVidia drivers don''t use Mesa3D or DRI or anything). Did you use the exact same version of the NVidia drivers that you did before? The 5xxx series was recently (a couple weeks ago) released, so if you just used the newest "then" and now you may have accidentally switched versions (of course: the 5xxx series is too unstable for me to recommend most people use it over the 4xxx series). Check the documentation for the driver version you''re using to see if it says anything about the environment variable you''re trying to use (and, if not, check some older versions).

Share this post


Link to post
Share on other sites
owl    376
Yes, they are exactly the same drivers.

I mentioned Mesa because when you install it, it overwrites some nvidia libraries or links and you have to reinstall your drivers in order to have hardware acceleration.

By the way, I''m using slackware here.

Share this post


Link to post
Share on other sites
C-Junkie    1099
Oh, well, slackware is your problem.



seriously, check the nvidia docs, you should be able to turn off vsync altogether by adding some driver option to XF86Config

Share this post


Link to post
Share on other sites
owl    376
The thing is that it worked before. Something changed from then to now, and I''m unable to figure out what... damn.

Share this post


Link to post
Share on other sites
Guest Anonymous Poster   
Guest Anonymous Poster
The variable is __GL_SYNC_TO_VBLANK=0 to turn it off. Make sure that''s what you''re setting (not GL_VSINC, which is the wrong variable and spelled wrong to boot). Also, make sure it''s exported to the global environment (ie, open a new terminal and echo it to make sure it worked).

Share this post


Link to post
Share on other sites
owl    376
quote:
Original post by Anonymous Poster
The variable is __GL_SYNC_TO_VBLANK=0 to turn it off. Make sure that's what you're setting (not GL_VSINC, which is the wrong variable and spelled wrong to boot). Also, make sure it's exported to the global environment (ie, open a new terminal and echo it to make sure it worked).


Yes, that's the one. I wasn't writting from home when I posted.

I checked it some hours ago with "set | grep GL" and it is there. (as it always was).

There is an XF86Config option I remeber I changed, one related to AGP mode, it is actually at "=1" (can be 1,2 or 3). But I'm sure that has nothing to do with vsinc.

EDIT: I understand now why it's good to keep a log of every move one do as root. This was my fault.

[edited by - owl on January 26, 2004 1:46:22 PM]

Share this post


Link to post
Share on other sites
owl    376
heh, guess what... the vsinc was always working perfectly

Before reconfiguring the system I changed something in my source code that automagically made the frame rate match the vsinc. heh, I''m a moron, I know

Share this post


Link to post
Share on other sites