Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

Spockmeat

Can't get lesson 35 to play

This topic is 5382 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I searched the boards and I didn''t find any errors like this. I can''t run the program at all. What happens is: it starts up, and then displays a message box saying "Failed to Open the AVI Frame" and then it just crashs when I hit ok. I downloaded bot the original code and the .net port for it, both compile and link just fine, but both the .exe''s that come in the zip and the ones I build all give the same error. Does anyone have a suggestion about what could be wrong? I''m running win2k3 server, visual studio.net 2003, and everything is completely updated.

Share this post


Link to post
Share on other sites
Advertisement
Hmm, it looks as though the call to:

AVIStreamGetFrameOpen(pavi, NULL);

is returning NULL.

A quick look at MSDN says that this is because a suitable decompressor is unavailable.

See Here

I''m not sure where you''d get a decompressor from. Sorry I can''t be of more help.

"To err is human, to really mess up requires a computer"

Share this post


Link to post
Share on other sites
Hey thanks
that was indeed the problem. I just ran the avi with windows media player and it automatically downloaded whatever codec it needed, and it all works now

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!