Archived

This topic is now archived and is closed to further replies.

program execution trouble!!!

This topic is 5048 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Has anyoe ever had trouble with a program exectuing fine through Visual Studio but not running properly when executed through windows(by double clicking .exe) or executing through command prompt. I have been developing a game using SDL and OpenGL on WIndows 2k with Visual C++ and have had it executing (release build) just fine through VC++ but have recently attempted to execute it other ways (the way a user might) and the program barely runs at all. Any help or insights would be much appreciated.

Share this post


Link to post
Share on other sites
be carefull - if you run your app from VS it sets the startup directory to X:\jadada\yourproject, but if u go to x:\jadada\yourproject\release and run it from there it''s gonna use x:\jadada\yourproject\release as it''s statup dir..

That''s about the only thing I can think of

Share this post


Link to post
Share on other sites
I don''t think that the startup directory is the problem. I copied all the resources into the /release directory. The program is finding all the appropriate resources it just runs incredibly slowly. So slowly in fact that my framerate calculator doesn''t rise higher than 0 fps (now that''s slow).

Share this post


Link to post
Share on other sites
Does the game display properly (albeit slowly)? In particular, are all textures rendered correctly?


"Sneftel is correct, if rather vulgar." --Flarelocke

Share this post


Link to post
Share on other sites