Archived

This topic is now archived and is closed to further replies.

ATI drivers

This topic is 5038 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am trying to install the drivers for my Radeon 9000 Pro under Debian, but it doesn't seem to be working. I downloaded the XFree86 4.2 driver Here, ran alien --to-deb filename, and installed the resultant file. There were no errors, but OpenGL programs still run really slow and the ATI Control icon in the menu does nothing. It seems like it isn't installed. [edited by - nagromo on February 22, 2004 9:21:30 PM]

Share this post


Link to post
Share on other sites
Did the XFree86-included DRI drivers not work for some reason? Or are you using a version of XFree86 that''s too old (4.2 is in testing and 4.3 is in unstable, now)? Did you not try to use them at all? If you''re not using the newest XFree86 that you can, that''s always a good first step (a newer version''s Radeon drivers might do all you need them to).

If none of that gives you any ideas: what''s the output of glxinfo and what does your XF86Config-4 file contain? Did you modify it any, possibly following some instructions that told you how to modify it (if there were any necessary modifications to use the closed Radeon drivers, which I''d guess there would be)?

Share this post


Link to post
Share on other sites
The included drivers work, but they seem to be using software emulation instead of my video hardware. I can run openGL apps, but they are very slow.

Here is the output of glxinfo:

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_ATI_pixel_format_float,
GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: VA Linux Systems, Inc.
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 Mesa 3.4.2
OpenGL extensions:
GL_ARB_multitexture, GL_EXT_abgr, GL_EXT_blend_color,
GL_EXT_blend_minmax, GL_EXT_blend_subtract
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x25 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x26 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None


It looks to me like it is using software emulation.

Here is my XF86Config-4:

# XF86Config-4 (XFree86 X server configuration file) generated by dexconf, the
# Debian X Configuration tool, using values from the debconf database.
#
# Edit this file with caution, and see the XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands as root:
#
# cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4 > /var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "ATI Radeon 9000 Pro"
Driver "ati"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Mag 770FSb"
HorizSync 30-60
VertRefresh 50-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Radeon 9000 Pro"
Monitor "Mag 770FSb"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection

Share this post


Link to post
Share on other sites
Did you run the "fglrxconfig" program that the driver package includes like the instructions say you should? I ask because I''m pretty sure that the device driver string would have changed to whatever it should be to use the new drivers if you had, but it appears to be what it should to use the default ATI drivers.

I tried to look up how to change it manually, but couldn''t find any official documentation on the matter, so I ran the executable through strings (and a group greps) and found that one should probably change the string to "fglrx". However, that may not be the only change, and you should probably just use their configuration program to do it all for you.

Share this post


Link to post
Share on other sites
OK, I just ran fglrxconfig without backing up my Xfree86 config file and messed up the X. I changed part of the fglrx section to fix it, though. Now I am right back where I was before... it seems like it should work but it doesn''t.

1) The ''ATI Control'' icon in the K menu doesn''t do anything (the cursor doesn''t even change to working)

2) When I run ''fglrxinfo'' it says:

display: :0.0 screen: 0
OpenGL vendor string: VA Linux Systems, Inc.
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 Mesa 3.4.2

when the example in the readme say:

OpenGL vendor string: ATI
OpenGL renderer string: FireGL 8700/8800
OpenGL version string: 1.2.1234 (1.2.3)

It seems like I am running the fglrx version because changing that fixed my problem, but fglrxinfo seems to say otherwise. I also re-installed the drivers and checked the troubleshooting in the readme. How can I turn on hardware acceleration when I can''t even get to the control center?

Share this post


Link to post
Share on other sites
What motherboard are you using? You might need to ensure that the appropriate AGPGART driver is loaded before X starts (as well as the fglrx driver)

i.e. for a VIA KT400

modprobe via_agp
modprobe fglrx




joeG

Share this post


Link to post
Share on other sites
OK, I am beginning to think that the drivers were never properly installed. Modprobe fglrx couldn''t find the module. Nothing that it installed seems to work. There were no error messages, though, and the driver shortcut and fglrxconfig were installed. I will reinstall the drivers when I get home.

Share this post


Link to post
Share on other sites