Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

bangz

Direct3D mesh problem...

This topic is 5402 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I''m getting a really strange problem. I''m rendering two objects, a mesh and an index buffer (both have different textures). But, for some reason, the index buffer object has just a black texture, although if I just comment out ''m_mesh->DrawSubset(i);'' the texture displays fine on the index buffer objects. I am not apply material propertise to either, and I also have lighting disabled. Changing the order that I render the objects doesn''t help. Does rendering a mesh set any states that I''m not aware of? regards, bangz. http://www.bangz.co.uk

Share this post


Link to post
Share on other sites
Advertisement
Could you post your render code? It should look something like this:

for(DWORD i = 0; i < dwNumMaterials; i++)
{
m_pd3dDevice->SetTexture(0,pMeshTextures[ i ]);
m_mesh->DrawSubset(i);
}

m_pd3dDevice->SetStreamSource(....);
m_pd3dDevice->SetIndices(....)
m_pd3dDevice->SetFVF(....);
m_pd3dDevice->SetTexture(0, pTexture);
m_pd3dDevice->DrawIndexedPrimitive(....)

neneboricua

[edited by - neneboricua19 on February 26, 2004 11:52:08 PM]

Share this post


Link to post
Share on other sites
Ahhh, cheers!

Your code reminded me that I wasn''t setting m_pd3dDevice->SetFVF(....); when I rendered my index buffer. Obviously when rendering the mesh it will change the vertex format. Doh!



Cheers,
bangz.

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

GameDev.net is your game development community. Create an account for your GameDev Portfolio and participate in the largest developer community in the games industry.

Sign me up!