Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

supagu

openal - is sound palying?

This topic is 5319 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

Advertisement
if you cant delete the opanal .dll''s(either in system system32 or the progs directory), then some program is using them to play sound!

I moderate at THESE forums.

Share this post


Link to post
Share on other sites
quote:
Original post by supagu
how to determine is openal sound is playing,

How about alGetSourcei with AL_PLAYING?

quote:
Original post by supagu
also is there a proper online html reference for openal?

Searching Google for "OpenAL reference" would have turned up this .

Share this post


Link to post
Share on other sites
quote:
Original post by supagu
yes its not very helpful reference :-/

Sure it is. Basically everything I know about OpenAL are from various incarnations of it and OpenAL''s source code.

What exactly do you expect a reference document to contain? Are you looking for something closer to tutorials? If so, Google has some suggestions as does the OpenAL page (in the "OpenAL Tutorials" section about half-way down that page). If you just need examples, there are some in OpenAL''s CVS that are likely packaged with Creative''s OpenAL "SDK" (I didn''t really like the examples when I last saw them, but they work well enough, I suppose).

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!