Jump to content
  • Advertisement

Archived

This topic is now archived and is closed to further replies.

LonelyTower

Setting SDL up for Visual Studio C++

This topic is 5341 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I followed the steps presented by several sites, as well as the book Data Structures for Game Programming, and finally end up with one warning:
quote:
MSVCRTD.lib(cinitexe.obj) : warning LNK4098: defaultlib "msvcrt.lib" conflicts with use of other libs; use /NODEFAULTLIB:library
What shall I do about this?

Share this post


Link to post
Share on other sites
Advertisement
In the extra linker options box put in /NODEFAULTLIB:msvcrt.lib and that should fix it.

[edit]Actually I'm not sure if there is an extra linker options box, it's ages since I used MSVC++, if there isn't find a text box with a caption like 'Libaries to ignore' or 'Ignore libaries' and put msvcrt.lib in it.


[edited by - Monder on March 7, 2004 7:00:42 AM]

Share this post


Link to post
Share on other sites
Hi,
Try to use Multithreaded Runtime libary instead of singletreaded.

c/c++ -> Code generation
somewhere there .. i can''t exactly tell where, cause i have the german version of vc7


Lazzar

Share this post


Link to post
Share on other sites
Set code generation to "Multi-threaded DLL." The issue isn''t whether or not it''s multithreaded, per se, but rather the fact that it''s dynamically linked (this being the same setting that SDL uses, and thus requires).

Share this post


Link to post
Share on other sites

  • Advertisement
×

Important Information

By using GameDev.net, you agree to our community Guidelines, Terms of Use, and Privacy Policy.

We are the game development community.

Whether you are an indie, hobbyist, AAA developer, or just trying to learn, GameDev.net is the place for you to learn, share, and connect with the games industry. Learn more About Us or sign up!

Sign me up!