• Advertisement

Archived

This topic is now archived and is closed to further replies.

Textures probelm...

This topic is 5100 days old which is more than the 365 day threshold we allow for new replies. Please post a new topic.

If you intended to correct an error in the post then please contact us.

Recommended Posts

I am trying to place a texture on a quad, but instead of the texture covering the whole quad it covers on 1/4 of the quad and than replicated. (basiclly it looks like the texture is applied 4 times on diffrent quaters of the quad).

Share this post


Link to post
Share on other sites
Advertisement
When you specify tex coords are they below or above 1.0? Any values above 1.0 will cause the texure to repeat by default.

Share this post


Link to post
Share on other sites
i use 1.0f notion

if i enter 4.0f notation the texture replicates itself EIGHT times, not four like it should.

Share this post


Link to post
Share on other sites
Not sure what you want if you want it to repeat 2 times in both directions, such making a total of 4 times the same texture, then you want to set the TC at 2.0f.
If you want it to repeat 4 times in both directions, then you need to set TV at 4.0f.


-* So many things to do, so little time to spend. *-

Share this post


Link to post
Share on other sites
well, the probelm is solved.

Apperantly for some unknow reason i decided to use the texture coords as

(-1,-1) and not(0,0)

Share this post


Link to post
Share on other sites

  • Advertisement